
  

 

Dear Candidate, 

In preparation for the Print & Digital Media Publication certification exam, we’ve put together a set of 
practice materials and example exam items for you to review.  What you’ll find in this packet are: 

§ Topic areas and objectives for the exam.  

§ Practice materials with image assets. 

§ Practice exam items. 

We’ve assembled excerpted material from the Adobe Digital Careers curriculum 
(http://edex.adobe.com/digital-careers) to highlight a few of the more challenging techniques covered 
on the exam. You can work through these technical guides with the provided image and video files 
(provided separately). Additionally, we’ve included the certification objectives so that you are aware of 
the elements that are covered on the exam. Finally, we’ve included practice exam items to give you a 
feel for some of the items.  

These materials are meant to help you familiarize yourself with the areas of the exam so are not 
comprehensive across all the objectives. 

Thank you, 

Adobe Education 
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Adobe Print & Digital Media Publication using Adobe InDesign  
EXAM AND OBJECTIVES 

After taking the exam, your score is electronically reported.  Please allow 2-4 weeks from the date you pass 
the exam to receive your ACA Welcome Kit. 

Exam Structure 
 
The following lists the topic areas for the exam:  

• Setting project requirements 

• Identifying design elements when preparing page layouts 

• Understanding Adobe InDesign 

• Creating page layouts by using Adobe InDesign 

• Publish, export and archive page layouts by using Adobe InDesign 
 
Number of Questions and Time 
  

• 39 questions  

• 50 minutes  

 
Exam Objectives 
 
Domain 1.0   Setting project requirements 

1.1        Identify the purpose, audience, and audience needs for preparing page layouts. 

1.2        Demonstrate knowledge of standard copyright rules for content use in page layouts. 

1.3        Demonstrate knowledge of project management tasks and responsibilities. 

1.4        Communicate with others (such as peers and clients) about design plans. 

Domain 2.0   Identifying design elements when preparing page layouts       

2.1  Demonstrate knowledge of the appropriate properties of page layouts for print, web and digital 
publishing. 

2.2  Demonstrate knowledge of design principles, elements and page layout composition. 

 

2.3  Demonstrate knowledge of typography. 

2.4  Demonstrate knowledge of the use of symbols and representative graphics. 

2.5  Understand key terminology of page layouts. 
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 Domain 3.0   Understanding Adobe InDesign  

3.1  Identify elements of the InDesign interface and demonstrate knowledge of their functions. 

3.2  Use non-printing design tools in the interface. 

3.3  Demonstrate an understanding of and select the appropriate features and options required to manage 
colors. 

3.4  Demonstrate knowledge of layers. 

3.5  Demonstrate knowledge of exporting, packaging, saving, and organizing files. 

Domain 4.0   Creating page layouts by using Adobe InDesign 

4.1  Demonstrate knowledge of how to create multiple-page documents. 

4.2  Demonstrate knowledge of how to use styles. 

4.3  Demonstrate knowledge of how to use frames in a page layout. 

4.4  Add text to a page layout. 

4.5  Add graphic, image, and video content to a page layout. 

4.6  Demonstrate knowledge of how to create special page elements using InDesign tools. 

4.7  Demonstrate knowledge of how to add interactive elements using InDesign tools. 

Domain 5.0   Publish, export and archive page layouts by using Adobe InDesign 

5.1  Demonstrate knowledge of how to prepare page layouts for publishing to print. 

5.2  Demonstrate knowledge of how to prepare page layouts for export to multiscreen devices. 

 
 



 
PRACTICE MATERIALS 

 
Print & Digital Media Publication  

by using Adobe InDesign 
 
 

• Overview of Adobe InDesign 
• How to setup a document 
• How to use text 
• How to work with graphic frames 
• How to place images, graphics, and videos on a page 
• How to create interactive documents 
• How to use styles, lists, columns and table of contents 
• How to prepare files for print 
• How to export for multiple screens 

 



Adobe InDesign Guide
Overview of Adobe InDesign
In this guide, you’ll learn how to do the following:

• Work with the InDesign workspace, tools, document windows, pasteboard, panels, and layers.

• Customize the workspace.

• Change the magnification of a document.

• Navigate through a document by using the Pages panel and page controls in the document window.

Exploring the workspace

The InDesign workspace encompasses everything you see when you first open or create a document: the Tools panel, 
document window, pasteboard, and other panels. You can customize and save the work area to suit your work style. 
For example, you can choose to display only those panels you frequently use, minimize and rearrange panel groups, 
resize windows, and add additional document windows.

Figure 1 Adobe InDesign workspace

The default workspace in InDesign (Figure 1) includes an Application bar at the top of the screen. Within this 
Application bar are the InDesign application icon, main menu, application controls, View controls, and the workspace 
switcher. Below this bar is the Control panel, the Tools panel on the left, panels on the right, and one or more 
document windows, which are opened separately.

The main menu organizes commands in individual menus.

The Control panel displays options for the currently selected tool.

The document window displays the file you’re working on. Each page or spread in a document is surrounded by its 
own pasteboard, which can store objects for the document as you create the layout.

The Tools panel contains tools for creating and editing images, artwork, page elements, and so on. Related tools are grouped 
together.

Workspace 
switcher 

Panels

Application 
bar

Control 
panel

Document 
window

Tools panel
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Panels help you monitor and modify your work. An example is the Layers panel.

Certain panels are displayed by default, but you can add any panel by selecting it from the Window menu. Many 
panels have menus with panel-specific options. You can separate, group, stack, and dock panels into your preferred 
layout. 

Customizing the workspace

By saving the current size and position of panels as a named workspace, you can restore that workspace even if you 
move or close a panel. The names of saved workspaces appear in the workspace switcher.

To create a custom workspace:

1. Move and manipulate the workspace layout in InDesign 
to suit your needs (Figure 2).

2. From the workspace switcher, select New Workspace 
(Figure 3).

The New Workspace dialog box appears (Figure 4).

3. Name your workspace and select the items to save in the 
workspace: your placement of panels is saved if you 
select the Panel Locations option; any keyboard shortcuts 
and menus you customized are saved if you select the 
Menu Customization option.

4. Click OK.

The name of your new workspace appears in the 
workspace switcher.

Figure 2 Custom workspace layout

Figure 3 Workspace switcher

Figure 4 New Workspace dialog box
Overview of Adobe InDesign © 2013 Adobe Systems Incorporated
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5. Choose Window > Workspace.

Notice that your new workspace now appears at the top 
of the Workspace menu.

Even if you make changes, you can return to the 
workspace you saved by selecting it from the menu or 
from the workspace switcher (Figure 5).

You can restore the saved workspace at any time by 
choosing Reset [your named] Workspace from the 
workspace switcher.

Figure 5 Selecting a saved workspace

Opening a file in InDesign

In general, you open document and template files the same way you do in other programs. When you open an 
InDesign template, it opens as a new, untitled document. Document files use the extension .indd, template files use 
the extension .indt, library files use the extension .indl, and book files use the extension .indb.

You can also use the File > Open command to open files from InDesign 1.x and later (including Asian-language 
versions), InDesign Interchange (.inx) files, Adobe PageMaker 6.0 and later, QuarkXPress 3.3 and 4.1, and 
QuarkXPress Passport 4.1. In addition, other software vendors may make plug-in software with which you can open 
other file formats.

To open an existing file:

1. Start InDesign.

2. Choose File > Open from the main menu.

You can also choose File > Open Recent to open an 
existing InDesign document.

Figure 6 InDesign File menu
© 2013 Adobe Systems Incorporated Overview of Adobe InDesign 3
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Tools panel overview

Some tools in the Tools panel (Figure 7) are for selecting, editing, and creating page elements. Other tools are for 
choosing types, shapes, lines, and gradients. You can change the overall layout of the Tools panel to fit your preferred 
window and panel layout.

Click a tool to select it from the default Tools panel. The Tools panel also contains several hidden tools related to the 
visible tools. Hidden tools are indicated by arrows to the right of the tool icons. Select a hidden tool by clicking and 
holding the current tool in the Tools panel and then selecting the tool you want.

The name of the tool and its keyboard shortcut appear when you hold the pointer over the tool—this text is called a 
tool tip. You can turn off tool tips by choosing None from the Tool Tips menu in General preferences (Windows) or 
Interface Preferences (Mac OS).

Figure 7 Overview of the Tools panel

A

B

C

D
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The Zoom tool

You can use the Zoom tool to change the magnification level in your document.

To use the Zoom tool to change the magnification:

1. Open a multipage document, examine the filename at the 
top of the document window, and notice the percentage 
listed at the end of the filename (Figure 8).

This represents the current enlargement view of the page, 
or zoom level.

2. Move the pointer over the Tools panel and hover over the 
magnifying-glass icon until a tool tip appears, identifying 
the tool by name and providing its keyboard shortcut 
(Figure 9). 

3. Select the Zoom tool by clicking the Zoom tool button in 
the Tools panel or by pressing Z, the keyboard shortcut 
for the Zoom tool.

4. Click anywhere in the document window.

The document zooms in according to a preset percentage 
level, which replaces the previous value in the document 
window. The location you clicked when you used the 
Zoom tool becomes the center of the enlarged view.

5. Using the Zoom tool, drag a rectangle to enclose a region 
of the document (Figure 10). 

The selection enlarges to fill the entire document 
window.

Figure 8 Document window with zoom level

Figure 9 Tool tip

Figure 10 Selecting a rectangular region
© 2013 Adobe Systems Incorporated Overview of Adobe InDesign 5
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6. To zoom out, Alt-click (Windows) or Option-click (Mac 
OS) (Figure 11).

Figure 11 Zooming out in a document

The Hand tool

The Hand tool moves a document within the document window. This is useful if you want to see a part of the document 
that is currently out of view.

To scroll around the document with the Hand tool:

1. Zoom into an area of your document until part of the 
page is out of view (Figure 12).

2. Select the Hand tool from the Tools panel (Figure 13). 

Figure 12 Document window with scroll bars

Figure 13 Hand tool
Overview of Adobe InDesign © 2013 Adobe Systems Incorporated
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3. Using the Hand tool, drag to scroll around and view 
different parts of the document (Figure 14).

Figure 14 Using the Hand tool to move around a 
document

How to select an object and work with the Control panel

The Control panel (Window > Control) offers quick access to options, commands, and other panels related to the 
current page item or objects you select (this is called contextual). By default, the Control panel is docked to the top of 
the document window; however, you can dock it to the bottom of the window, convert it to a floating panel, or hide it 
altogether

To use the Selection tool and Control panel:

1. With a document open, choose the Selection tool from 
the Tools panel and then select an object in your 
document.

Notice that the Control panel information reflects such 
things as the position, size, and rotation of that object 
(Figure 15).

2. Next, choose the Type tool and select a region of text.

The Control panel changes to show options that provide 
control over text formatting (Figure 16).

Figure 15 Control panel with image selected

Figure 16 Control panel with text selected
© 2013 Adobe Systems Incorporated Overview of Adobe InDesign 7
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Navigating through the pages in your document

You can turn pages by using the Pages panel, the page buttons at the bottom of the document window, the scroll bars, 
or a variety of other commands.

To navigate through a document:

1. You can move from one page to another by using the 
arrow controls in the lower left corner of the document 
window (Figure 17). Click the forward arrow to go to the 
next page and the back arrow to go to the previous page.

An arrow control is dimmed if there is no page to go to. A 
pop-up menu also allows you to navigate by page 
number.

2. A second way to navigate your document is by using the 
Pages panel (Figure 18). This panel lists document 
layout templates in the top section and actual pages in the 
lower section. To choose a page in your document, 
double-click the page icon in the lower section.

The document window displays the selected page.

3. You can also go directly to a particular page by choosing 
Layout > Go To Page and then entering the page number 
(Figure 19).

Figure 17 Using the controls at the lower left of the 
document window

Figure 18 Using the Pages panel to navigate

Figure 19 Using a menu command to navigate
Overview of Adobe InDesign © 2013 Adobe Systems Incorporated
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Working with layers

Each document includes at least one named layer. By using multiple layers, you can create and edit specific areas or 
kinds of content in your document without affecting other areas or kinds of content. For example, if your document 
prints slowly because it contains many large graphics, you can use one layer for just the text in your document; then, 
when it’s time to proofread the text, you can hide all other layers and quickly print the text layer only. You can also 
use layers to display alternate design ideas for the same layout, or versions of advertisements for different regions.

Think of layers as transparent sheets stacked on top of each other. If a layer doesn’t have objects on it, you can see 
through it to any objects on layers behind it.

You can draw objects in a document and use them as paths or as frames. Paths are vector graphics like those you 
create in a drawing program such as Adobe Illustrator. Frames are identical to paths, with only one difference—they 
can be containers for text or other objects. A frame can also exist as a placeholder—a container without contents. As 
containers and placeholders, frames are the basic building blocks for a document’s layout.

To create layers and work with objects:

1. Choose Window > Layers. 

The Layers panel opens (Figure 20). Notice there is an 
existing layer labeled Layer 1. You will use this layer as 
the background.

2. Double-click Layer 1 in the Layers panel.

The Layer Options dialog box opens (Figure 21).

3. Specify the layer options in the Layer Options dialog 
box, and then click OK.

Color Assigns a color to identify the objects on that layer.

Show Layer Makes a layer visible. Selecting this option is 
the same as making the eye icon visible in the Layers 
panel.

Show Guides Makes the guides on the layer visible. 
When this option is not selected for a layer, the guides 
cannot be made visible, even by selecting View > Show 
Guides for the document.

Lock Layer Prevents changes to any objects on the layer. 
Selecting this option is the same as making the crossed-
out pencil icon visible in the Layers panel.

Lock Guides Prevents changes to all ruler guides on the 
layer.

Print Layer Allows the layer to be prevented from 
printing. When printing or exporting to PDF, you can 
determine whether to print hidden and non-printing 
layers.

Suppress Text Wrap When Layer Is Hidden Makes text on 
other layers flow normally when the layer is hidden and it 
contains objects with text wrap applied.

4. In the Tools panel, select the Rectangle tool.

Figure 20 Layers panel

Figure 21 Layer Options dialog box

New Layer button
© 2013 Adobe Systems Incorporated Overview of Adobe InDesign 9
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5. Drag in the document window to create the background 
shape in the document (Figure 22).

6. Double-click the Fill box in the Tools panel (Figure 23).

The color Color Picker opens (Figure 24).

Fill displays the selected color you select.

7. Click OK. 

8. Create a new layer by clicking the New Layer button in 
the Layers panel.

This is Layer 2, into which you will import a graphic.

9. In the Tools panel, select the Rectangle Frame tool.

10. Drag in the document window to create the foreground 
frame in the document into which you want to place a 
graphic (Figure 25). Make sure the shape is the proper 
orientation to fit the image, but don’t worry about the 
exact size because you can fix that later.

Figure 22 Dragging the Rectangle Tool in the 
document window

Figure 23 Fill and Stroke tools in the Tools panel

Figure 24 Color Picker

Figure 25 Creating a graphics frame

Fill

Stroke

Apply Color
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11. Choose File > Place.

The Place dialog box opens (Figure 26).

12. Select a graphics file.

13. Click Open.

The image is placed inside the document in the layer.

14. Select Object > Fitting. 

There are several options for fitting the content to the 
frame or the frame to the content (Figure 27). 

If the new image is smaller or larger than the frame and 
you want to maintain the image aspect ratio, you can refit 
the content by choosing Object > Fitting > Fit Content 
Proportionally. 

The placed object is fit into the frame (Figure 28).

15. In the Layers panel, click on a layer’s disclosure triangle 
to reveal the objects and their stacking order on that 
given layer for the active spread (Figure 29). 

You can change the stacking order of objects by dragging 
items up or down in the list. In the Layers panel you can 
also show or hide and lock or unlock individual page 
items.

Figure 26 Place dialog box

Figure 27 Object fitting options

Figure 28 Object placed with a frame 

Figure 29 Layers panel with expanded layers
© 2013 Adobe Systems Incorporated Overview of Adobe InDesign 11
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How to set up a document
When working in Adobe InDesign, your first step is to create a new document. When creating a new document, you 
can specify the intended format: Print, Web, or Digital Publishing and set dimensions, margins, and other 
characteristics for the document.You can edit any of these settings after the document is created.

This guide explains how to create a new document with the dimensions of a business card.

Creating a new document

In the following steps, you first change preferences so you view document dimensions in inches, and then create a 
new document. By default, InDesign measures documents in picas. Picas are a standard print measurement unit; there 
are 72 picas to an inch. As you advance in layout design, you may find it useful to work in picas. To start, though, it 
will be easier to think in terms of inches.

To create a new document:

1. Start InDesign and choose Edit > Preferences > Units & 
Increments (Windows) or InDesign > Preferences > Units 
& Increments (Mac OS).

The Preferences dialog box appears with the Units & 
Increments section selected (Figure 1).

2. Select Inches in the Horizontal and Vertical pop-up 
menus.

This sets the document’s horizontal and vertical unit of 
measurement to inches.

Note: If you are used to working with points and picas, 
keep the measurements at their default.

3. Leave other settings unchanged, and click OK to close 
the Preferences dialog box.

4. Choose File > New > Document.

The New Document dialog box appears (Figure 2). 
Because you changed ruler units to inches, the Page Size, 
Margins, and the other dimensions appear in inches.

5. Deselect Facing Pages.

Because this document is only one page, you do not need 
facing pages.

In a facing page spread, pages sit opposite one another. 
Books and magazines usually have facing pages.

When you select the Facing Page option, InDesign treats 
each pair of facing pages as one spread, and you can 
work on laying out both pages at once.

6. In the Width box, type 3.5. In the Height box, type 2.

This is the standard dimension for a US business card.

For other documents, of course, you would enter different 
settings. For example, a standard page in the United 
States is 8.5 inches by 11 inches.

Figure 1 Units & Increments section of the 
Preferences dialog box

Figure 2 New Document dialog box
© 2013 Adobe Systems Incorporated How to set up a document 1
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7. Leave Columns set to 1.

If this were a document with multiple columns of text, 
you could set multiple columns here.

8. In the Margins section, make sure the Make All Settings 
The Same icon (the chain link) is selected.

This setting tells InDesign to set all margins to the same 
value.

You will often want to set margins the same to give 
documents a uniform appearance. If you want to set 
different margins for top, bottom, left, and right, leave the 
Make All Settings The Same icon deselected, and enter 
widths for each margin.

9. Type .25 in the Top box and press the Tab key.

All margins change to .25 inches.

10. Click OK.

The new document opens in InDesign (Figure 3).

Observe that the margins are marked by a margin guide. 
Also observe that the rulers along the left and across the 
top are marked in inches.

Figure 3 New InDesign document

Using multiple page sizes

You can define different page sizes for pages within a single document. This feature is especially useful when you 
want to manage related designs in one file. For example, you can include business card, letterhead, and envelope 
pages in the same document (Figure 4). 

Figure 4 Multiple page sizes in same document

Business card

Letterhead

Envelope
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To create different page sizes within a document:

Use the Page panel to select the master page or layout page you want to resize, and then modify the page settings. 

1. Choose File > New > Document.

The New Document dialog box appears (Figure 5). The 
New Document dialog box combines the Document 
Setup and the Margins And Columns dialog boxes, so 
that you can set up the page size, margins, and page 
columns all in one place. 

2. Confirm the Page Size is set to Letter, and specify other 
document setup options. For example, enter 3 in the 
Number Of Pages text box as this project needs a 
document with three pages. Leave the other settings as 
they are for now. You can change these settings later to 
define the custom page sizes.

3. Deselect the Facing Pages option to let each page stand 
alone. 

4. Click OK to open a new document with the settings you 
specified.

5. If the Pages panel isn’t visible, choose Window > Pages.

6. In the document, select the first page by clicking it.

Observe that page 1 is selected in the Pages panel 
(Figure 6).

7. Click the Edit Page Size button in the Pages panel, and 
select US Business Card. 

The page size is altered to 3.5 inches by 2 inches.

8. Next modify the default margins for the business card. 
Choose Layout > Margins And Columns. 

The Margins and Columns dialog box opens (Figure 7).

9. Type .25 in the Top box and press the Tab key.

All margins change to .25 inches.

10. Click OK to accept the new margin settings.

11. In the Pages panel, double-click the third page. 

Observe that page 3 is also selected in the document.

Figure 5 New Document dialog box

Figure 6 Pages panel

Figure 7 Margins And Columns dialog box

Edit Page Size button
© 2013 Adobe Systems Incorporated How to set up a document 3
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12. Click the Edit Page Size button and select Custom Page 
Size.

The Custom Page Size dialog box opens (Figure 8).

13. In the Width box, type 9.5. In the Height box, type 4.125.

These are the standard dimensions for a #10 commercial 
envelope in the United States.

14. Click OK.

The three-page layout is ready for use (Figure 9).

Figure 8 Custom Page Size dialog box

Figure 9 InDesign layout using multiple page sizes
How to set up a document © 2013 Adobe Systems Incorporated
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How to use text
Because Adobe InDesign is a page layout tool, working with text is an important skill. With InDesign, you add all 
text (and all content) into frames. Frames are shapes (called paths) that hold content on a page. You can’t add text 
without adding a text frame, and that’s a good thing, because frames offer you a wide range of possibilities for 
formatting and positioning text and for controlling text flow—how text continues from frame to frame.

In this guide, you’ll learn to add text frames and to apply basic formatting—such as font family, font size, and text 
color—and advanced text formatting—such as leading, kerning, tracking, and shifting the baseline. Advanced text 
composition options give you greater control over how paragraphs appear in the final document.

Adding a text frame

In InDesign, you place all text within text frames. The easiest way to create a text frame is with the Type tool.

Note: You can also create text frames with the frame tools. Using the Ellipse Frame tool and Polygon Frame tool, you 
can create text frames that are non-rectangular, such as a circle, hexagon, or star.

To create a text frame with the Type tool:

1. Start InDesign and create a new document.

2. Select the Type tool in the Tools panel (Figure 1).

The pointer changes to the Type tool pointer (a text 
insertion icon bordered by a dotted line).

3. Drag the Type tool across the page to create a Text frame 
(Figure 2).

To help you position the frame, you may find it useful to 
show the Document grid (View > Grids & Guides > 
Show Document Grid).

As you drag, a blue box appears (Figure 2), with an 
indicator for width and height.

4. Release the mouse button to create the text frame.

Observe that a blinking text-insertion point appears in the 
text frame.

5. Type some text, such as your name.

The text appears in whatever font family, font size, and 
other text settings were previously set in the Type Control 
panel.

Figure 1 Tools panel

Figure 2 Dragging to create a text frame

Selection tool

Type tool
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6. Without moving the insertion point, click the Selection 
tool at the top of the Tools panel (Figure 1).

Frame handles appear at the edges of the text frame 
(Figure 3). You can drag these handles to resize the text 
frame.

You can recognize text frames by the text ports—empty 
squares that are larger than frame handles—on their left 
and right sides. You use text ports to make connections 
between text frames.

Figure 3 Frame handles on text frame

Formatting text

In layout, the appearance of text is an art in itself. Although much of your text’s impact will derive from its 
typography (the font you choose for your text), you can fine-tune its appearance by adjusting a number of additional 
factors. Such fine-tuning is especially important for titles and other large-set text, because you want this text to stand 
out to create interest, and readers will notice subtle adjustments to large-set text more than to text set in smaller sizes.

You format text by using the Control panel (Figure 4).

Figure 4 Type Control panel

Selecting text and applying basic formatting to text

To change the color of text, you first need to select it. (Text will not change if you change settings with only the text 
frame selected.) You can use the Control panel and Tools panel to modify the font, color, and stroke of text. Fill refers 
to the color inside the outline of a character. Stroke refers to the outline itself. By default, characters do not have a 
stroke applied. 

Finding and managing fonts

Finding the perfect font to suit your design project can be a daunting task. You can use the Fonts widget in the 
Character panel and the Type Control panel to display, search, and select fonts (Figure 4). You can also identify 
Favorite fonts for easy access, and apply fonts on selected text while browsing so that you can see how your fonts will 
look in the layout.

Text port Frame handle

All caps KerningFonts widget Alignment

Select character or 
paragraph style Font size

Strikethrough

TrackingLeading JustifyFont style

Small caps

Underline Character style
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Fonts widget

Searching fonts

Browsing and applying fonts

You can browse the fonts list with the Arrow keys. On selection, the font style is applied to the selected text in your 
layout or document for preview. Clicking a font name or pressing the Enter key commits the font style and closes the 
Font List popup.

The Fonts widget has four elements (Figure 5):

1. Button control to toggle between the two available 
search modes

2. Text field to display selected font name or enter the 
search keyword

3. Clear search icon; appears only when some text is 
entered in the search field

4. Drop-down arrow button to display the font list – all 
fonts or search results

Figure 5 Fonts widget

Clicking the drop-down arrow button without entering any 
search string displays a pop-up list of all installed fonts 
(Figure 6).

Figure 6 Pop-up list of all installed fonts

You can search for fonts by typing in the text field. As you 
clear the font name and start typing, the search results start 
appearing in the popup. A Cross icon appears in the widget to 
help you clear off the results quickly and start afresh. The 
search results are displayed as a flat list (without grouping of 
font and associated family). For example, Ebrima is a family 
and has two styles – Regular and Bold. If you search for 
Ebrima, both Regular and Bold are displayed as separate 
entries and are not grouped as Ebrima (Figure 7). 

Figure 7 Font search pop-up
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Managing your favorite fonts

To select text:

1. Choose the Type tool.

2. Click in a text frame with text.

3. Drag the pointer over the text to select it (Figure 10).

The text is highlighted.

4. Use the Font widget to choose a different font family in 
the pop-up menu, such as Franklin Gothic Medium.

5. Choose a different font size in the Font Size pop-up 
menu, such as 18 pt.

6. Click the Small Caps button.

With Small Caps, all lowercase letters appear as small 
uppercase letters.

7. Double-click the Fill box in the Tools panel (Figure 11).

The Color Picker opens (Figure 12).

When you have text selected, the Fill box appears with a 
small “T.”

8. Select a color for the text fill in the Color Picker.

9. Click OK.

The text changes fill color.

Figure 10 Text selected

Figure 11 Fill and Stroke tools in the Tools panel

You can add or remove a font from the Favorite list by click-
ing the Favorite icon (star) in the font list. When you click the 
drop-down arrow key, you see the Favorite icon highlighted 
in Black for the fonts which are marked as favorite 
(Figure 8). Adding or removing a font belonging to a family 
adds or removes the entire font family to the Favorite list 
(Figure 9).

Figure 8 Favorite fonts pop-up

Figure 9 Font family in Favorite fonts pop-up

Fill

Stroke

Apply Color
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10. Double-click the Stroke box in the Tools panel.

The Color Picker appears.

11. Select a color for the text stroke in the Color Picker.

12. Click OK.

The text changes stroke color.

13. Click away from the text to deselect it and observe your 
results (Figure 13).

Figure 12 Color Picker

Figure 13 Basic text formatting applied

Adjusting text spacing and applying baseline shift

To improve readability and meet design goals, you can also adjust the spacing between lines and characters—leading, 
tracking, and kerning—and change the vertical location of some characters—baseline shift.

Adjusting leading

Leading refers to the space between lines. You’re probably used to differentiating between single-spaced and double-
spaced text. By adjusting leading, you can fine-tune the space between lines.

To adjust leading:

1. With the Text tool, select some text.

2. Choose a value in the Leading pop-up menu (Figure 14). 

You can also enter a numeric value in the Leading menu’s 
text box.

For example, 24-point leading was applied to the 12-
point text in Figure 15.

Figure 14 Leading menu in the Control panel

Figure 15 Leading applied to text

Leading pop-up menu
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Adjusting tracking

Tracking refers to the space between characters across a line of text. When you adjust tracking, you can space the 
letters further apart. (You will usually not want to reduce tracking unless you’ve already increased it.)

Tracking is measured in 1/1000 em. Em is relative to the current type size. In a 12-point font, 1 em equals 12 points; in 
a 10-point font, 1 em equals 10 points. To give characters dramatic spacing, you need to enter fairly high numbers in 
the Tracking box—at least 300.

To adjust tracking:

1. Select some text.

2. Choose a value in the Tracking pop-up menu 
(Figure 16). 

You can also enter a numeric value in the Tracking pop-
up menu’s text box.

For example, tracking of 500 was applied to the 18-point 
text in Figure 17.

Figure 16 Tracking menu in the Control panel

Figure 17 Tracking applied to text

Adjusting kerning

Kerning refers to the space between any two characters. By default, InDesign applies metrics kerning to your text. 
Metrics kerning automatically adjusts the space between letters so letter pairs that produce gaps—such as LA, Pa, Ta, 
We, and Yo—have spacing consistent with letter pairs that do not produce gaps. These letter pairs are called kerning 
pairs and are included with most fonts.

For fonts that do not include such pairs (which is rare), you can use another kind of automatic kerning called optical 
kerning. Optical kerning adjusts the space between letters, based on their shapes. Optical kerning is also useful when 
you use two different typefaces or sizes in one or more words on a line.

You may also want to adjust kerning manually. Usually, you only need to adjust it for large font sizes or when you want 
the letters to look very close together. To adjust kerning between letters, click between them and change settings in the 
Kerning pop-up menu in the Control panel (Figure 18).

Figure 18 Kerning menu in the Control panel

Applying baseline shift

A font’s baseline is the lowest point of letters that do not extend below the baseline the way y and g do. You can use 
baseline shift to adjust the baseline for one or more characters.

Tracking pop-up menu

Kerning pop-up menu
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• If you enter a positive number in the Baseline Shift pop-up menu, the text moves up from the baseline.

• If you enter a negative number in the Baseline Shift pop-up menu, the text moves down from the baseline.

To apply baseline shift:

1. Select the character to which you wish to apply baseline 
shift.

2. Click in the Baseline Shift pop-up menu, and then press 
the Up or Down Arrow key to adjust the character’s 
baseline (Figure 19).

For example, in Figure 20, the baseline for the J and L 
has been adjusted negatively.

Figure 19 Baseline Shift menu in the Control panel

Figure 20 Baseline shift applied to text.

Managing overset text

As you make formatting changes—especially changes that increase the total amount of space occupied by text—you 
may create overset text. Overset text refers to text that does not fit in the text frame. When text is overset, a red plus 
(+) will appear in the right text port (Figure 21).

Figure 21 Frame with overset text

In these cases, you can take one of three actions:

• Reduce font size, leading, or tracking so that the text fits into the frame.

• Increase the size of the text frame.

• Flow excess text into another text frame. (For more information on this option, see InDesign Help and the 
“How to manage text flow between frames” guide.)

Baseline Shift pop-up menu

Indicates text is overset
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Advanced text composition

The appearance of text on your page depends on a complex interaction of processes called composition. Using the 
word spacing, letterspacing, glyph scaling, and hyphenation options you’ve selected, InDesign composes your type in 
a way that best supports the specified parameters.

InDesign offers two composition methods: Adobe Paragraph Composer (the default) and Adobe Single-line 
Composer. You can select which composer to use from the Paragraph panel menu, the Justification dialog box, or the 
Control panel menu at the right end of the Control panel.

The Paragraph Composer considers where to place line breaks and can respace earlier lines in the paragraph (based 
on such principles as evenness of letterspacing, word spacing, and hyphenation) in order to eliminate unattractive 
breaks later in the paragraph. The result is paragraphs with even spacing and fewer hyphens.

The Single Line Composer offers a traditional approach to composing text one line at a time. This option is useful if 
you want to deal with paragraph composition in the last stages of your document production.

Suppose you want to precisely control word spacing and letterspacing, as well as the width of characters in a set of 
justified paragraphs. You can use the Paragraph Composer to do this.

To set a composition method for a paragraph:

1. Select some text that contains multiple paragraphs.

2. Choose Type > Paragraph.

The Paragraph panel opens (Figure 22).

3. Choose Justification from the Paragraph panel menu.

The Justification dialog box opens (Figure 23)

4. Change the default values to the following values in the 
Justification dialog box:

• Word Spacing Minimum 60%, Maximum 150%

• Letter Spacing Minimum -50%, Maximum 150%

• Glyph Scaling Minimum 80%, Maximum 120%

• Auto Leading 140%

The Minimum and Maximum values define a range of 
acceptable spacing for justified paragraphs only. The 
Desired value defines the desired spacing for both 
justified and unjustified paragraphs:

Word Spacing The space between words that results from 
pressing the spacebar. Word Spacing values can range 
from 0% to 1000%; at 100%, no additional space is 
added between words.

Letter Spacing The distance between letters, including 
kerning or tracking values. Letter Spacing values can 
range from -100% to 500%: at 0%, no space is added 
between letters; at 100%, an entire space width is added 
between letters.

Glyph Scaling The width of characters (a glyph is any 
font character). Glyph Scaling values can range from 
50% to 200%.

Figure 22 Paragraph panel

Figure 23 Justification dialog box

Paragraph menu
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5. Set the Single Word Justification option to specify how 
you want to justify single-word text lines.

Note: In narrow columns, a single word can occasionally 
appear by itself on a line. If the paragraph is set to full 
justification, a single word on a line may appear to be too 
stretched out. Instead of leaving such words fully 
justified, you can center them or align them to the left or 
right margins.

6. Click OK.

The Adobe Paragraph Composer lays out the paragraph 
text (Figure 24). Observe how the text is justified 
according to the settings you entered in step 4.

Figure 24 Paragraph text justified with last line 
aligned left
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How to work with graphics frames
In Adobe InDesign, you locate all graphics within frames. A graphics frame determines what parts of the frame’s 
content (such as TIFFs, JPEGs, PDFs, PSDs, and AIs) appear on a page. You can also change the size and shape of 
the frame’s content, and adjust its transparency and tint settings.

This guide covers the following topics:

• Drawing graphics frames

• Adding content to a graphics frame

• Applying a stroke to a graphics frame

• Changing the size or shape of a graphics frame

• Changing the size or shape of graphics frame contents

• Modifying transparency and applying tints to graphics frames

Creating a rectangular graphics frame

1. Start InDesign and create a new document.

2. Select the Rectangle Frame tool in the Tools panel 
(Figure 1) and drag the pointer to create a graphics 
frame.

The frame has a crossbar through it, indicating that this is 
a graphics frame.

Figure 1 Tools panel

Creating a non-rectangular graphics frame

To create non-rectangular graphics frames, such as ellipses or polygons, use the Ellipse Frame tool or the Polygon 
Frame tool.

To create an elliptical graphics frame:

1. Click the Rectangle tool in the Tools panel, hold down 
the mouse button, and then select the Ellipse Frame tool 
(Figure 2).

Figure 2 Ellipse Frame tool

Rectangle Frame tool

Selection tool

Direct Selection tool
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2. Drag the pointer to create an elliptical frame (Figure 3).

Observe that the frame has a crossbar through it, 
indicating that this is a graphics frame.

Figure 3 Elliptical frame

Adding an image to a graphics frame

The Place command is the primary method used to import graphics into InDesign because it provides the highest 
level of support for resolution, file formats, multipage PDFs, and color. 

To add an image to a graphics frame:

1. Click the Selection tool in the Tools panel (Figure 1).

2. Select a graphics frame.

3. Choose File > Place.

The Place dialog box appears (Figure 4).

4. Make sure the Show Import Options option is deselected.

The Show Import Options option is generally 
unnecessary for images such as JPEGs and TIFFs.

5. Select the Preview option (Windows), and select the 
Replace Selected Item option (Figure 4).

When the Preview option is selected, a thumbnail of the 
image appears in the lower-right corner of the Place 
dialog box (Windows).

When you select the Replace Selected Item option, 
InDesign replaces whatever content is in the currently 
selected frame with your new image.

6. Browse to the location of the file you want to place.

Figure 4 Place dialog box

Replace Selected Item option Preview option
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7. Select the file and click Open.

The graphic is added to the graphics frame. If the graphic 
is larger than the frame, only a portion of the graphic 
shows.

8. Select Object > Fitting. 

This menu provides several options for fitting the content 
to the frame or the frame to the content (Figure 5).

If the new image is smaller or larger than the frame, you 
can refit the frame by choosing Object > Fitting > Fit 
Content To Frame. 

The placed object is fit to the frame (Figure 6).

Figure 5 Object fitting options

Figure 6 Placed object fit to frame

Applying a stroke to a graphics frame

A stroke is the border around a frame. By default, frames have no stroke. You add one by using the Stroke panel. You 
can also change the color of the stroke by using the Stroke box in the Tools panel.

To add a stroke to a graphics frame:

1. Click the Selection tool in the Tools panel (Figure 1).

2. Click the edge of a graphics frame to select it.

If you do not have a graphics frame created, create one by 
using one of the Frame tools.

3. Choose Window > Stroke to display the Stroke panel 
(Figure 7).

Note: You can display the Stroke panel with either 
limited options or expanded options (as is shown in 
Figure 7). To hide or expand the options, choose Hide 
Options or Show Options from the Stroke panel menu.

Figure 7 Stroke panel

Stroke 
panel menu
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4. Enter 5 pt in the Weight text box.

A 5-point stroke is applied to the graphics frame 
(Figure 10). The more you increase point size for the 
stroke, the thicker the stroke will be.

5. Double-click the Stroke box in the Tools panel 
(Figure 8).

The Color Picker appears (Figure 9).

6. Choose a color in the Color Picker by clicking 
somewhere in the square on the left side.

7. Click OK to close the Color Picker.

The stroke is now the color you chose in the Color Picker 
(Figure 10).

Figure 8 Tools panel

Figure 9 Color Picker

Figure 10 Stroke applied to graphics frame

Fill 

Apply 
Color 

Stroke
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Changing the shape of a graphics frame

InDesign provides a number of options for changing the shape of a graphics frame. As you change the shape of a 
graphics frame, it restricts the view of the image contained in the frame.

To change the shape of a graphics frame:

1. Select the Direct Selection tool in the Tools panel 
(Figure 1).

2. Drag one of the corners to change the shape of the frame 
(Figure 11).

3. Release the mouse button to accept the change. 

The frame’s shape has changed what part of the image 
you see.

4. Move the pointer over one of the frame’s edge segments 
(not over a selection handle).

The pointer changes to an arrow with a bar (Figure 12).

5. Drag the edge of the frame to change its shape .

6. Release the mouse to accept the change (Figure 13). Figure 11 Dragging a corner to change frame 
shape

Figure 12 Move Segment pointer

Figure 13 Move edge applied
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Changing the shape of an image without changing the frame

You can change the shape of a frame’s content—its image—independent of the frame itself.

To change the shape of an image but not the frame:

1. Select the Selection tool in the Tools panel (Figure 1).

2. Select the frame.

3. Choose Object > Select > Content to select the graphics 
frame’s content (Figure 14).

A brown bounding box appears in the shape of the 
original image.

4. Drag a corner of this bounding box to change the size of 
the image independent of the frame (Figure 15).

To change the image uniformly, hold down the Shift key 
as you drag the corner.

5. Release the mouse to accept the change (Figure 16).
Figure 14 Frame content selected

Figure 15 Dragging a corner to change frame 
shape

Figure 16 Image shape changed

Modifying transparency and applying tints to graphics frames

You may want to fine-tune the look and feel of a graphics frame to suit a particular mood or concept. For example, 
adjust the transparency of an image so that an underlying artwork becomes visible through the surface of the object, 
stroke, fill, or text. Or apply a tint to an individual object, stroke, fill, or text. These changes are easily accomplished 
using the Effects and Swatches panels in InDesign. 
How to work with graphics frames © 2013 Adobe Systems Incorporated
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In this section, two images are layered one on top of the other and the transparency is adjusted so that a background 
image shows through slightly. A rectangular footer frame is added on top and tint and transparency are applied to 
create a multi-layered image.

To change transparency and apply a tint to a frame:

1. Select the Rectangle Frame tool in the Tools panel and 
drag the pointer to create a graphics frame, and place an 
image in the background.

2. Click the Selection tool in the Tools panel and select the 
graphics frame.

3. Choose File > Place and import an image into the 
graphics frame.

4. Use the Object > Fitting menu to scale the image to fit as 
needed.

5. Place another graphics frame on top of the first frame and 
make it the same size.

To help match the second frame size, turn on smart 
guides (Figure 17) by choosing View > Grids & Guides 
> Smart Guides. Smart Guides makes it easy to snap 
objects to items in your layout. As you drag or create an 
object, temporary guides appear, indicating that the 
object is aligned with an edge or center of the page or 
with another page item. 

6. Import an image into the topmost graphics frame and 
scale the image to fit.

7. Click the Selection tool in the Tools panel and select the 
graphics frame.

8. Choose Window > Effects to display the Effects panel.

The Effects panel opens (Figure 18).

9. Select the arrow next to Opacity box and drag the 
Opacity slider, or enter a percentage measurement in the 
number box to achieve a degree of transparency so that 
the background image shows through slightly 
(Figure 19).

Figure 17 Smart Guides

Figure 18 Effects panel

Figure 19 Image opacity set to 55%

Opacity 
slider
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10. Select the Rectangle Frame tool and draw a third., 
smaller graphics frame over the previously-created 
frames.

11. Click the Selection tool in the Tools panel and select the 
graphics frame.

12. Click the Swatches button in left of the workspace to 
open the Swatches panel (Figure 20).

13. In the Swatches panel, select a color swatch.

The graphics frame is filled with the selected swatch 
(Figure 21). 

14. Select the arrow next to the Tint box and drag the Tint 
slider, or enter a tint value in the Percentage box, to 
achieve the desired degree of tint (Figure 22).

15. To preserve the new tint in the Swatches panel for 
additional use, click the New Swatch button.

The new color swatch is added to the Swatch panel 
(Figure 23).

Figure 20 Swatches Panel

Figure 21 Frame filled with color

Figure 22 Tint set to 50%

Figure 23 Swatches Panel

Tint slider

Tint slider
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How to place images, graphics, and videos on a page
To add images, graphics, videos and sound to an Adobe InDesign page, you need to place them on the page within a 
graphics frame. 

InDesign supports most major image and graphic formats: including TIFF, BMP, JPEG, PDF, PSD, and AI. You can 
place any of these formats on a page and resize an image and its frame independently. This gives you a wide degree of 
control over how your image appears on the page. When you place images on a page, you are actually placing a link 
from the page to the graphics file. When the page is printed, InDesign prints the image on the page according to your 
specifications.

Supported video and sound formats include: FLV, F4V, SWF, MP4, and MP3. Movie files are handled a little 
differently than images. You import a movie or sound file by double-clicking and a media frame is automatically 
created. If you were to drag to create a media frame, this could cause the movie boundary may appear cropped or 
skewed. Like images, if you move a linked media clip after adding it to a document, use the Links panel to relink it. 
Movies and sound clips you add to a document can be played when the document is exported to an interactive Adobe 
PDF or HTML. 

Placing images on a page without first creating a graphics frame

You use the Place command to put images and other objects on a page. You can put images and other objects on a 
page either within a frame or without first creating a frame. You may find it more precise to first create a graphics 
frame and then place the image within the frame. If you place an image on a page without first creating a frame, 
InDesign automatically creates a graphics frame around the image.

To place an image on the page without a graphics frame:

1. Create a new document in InDesign.

2. Choose File > Place.

The Place dialog box appears (Figure 1).

3. Browse to the location of the file you want to place.

4. Make sure the Show Import Options and Replace 
Selected Item options are deselected.

You can use the Show Import Options option to manage 
advanced options for placed images. This option 
becomes more important when you place image formats 
such as Adobe Photoshop and Adobe Illustrator files.

When you select the Replace Selected Item option, 
InDesign replaces whatever content is in the currently 
selected frame with your new image.

5. Make sure the Preview option is selected (Windows).

A thumbnail of the image appears in the lower-right 
corner of the Place dialog box (Windows).

6. Select the file and click Open.

The Place dialog box closes and the pointer changes to a 
Loaded Graphics icon, with a thumbnail of the image.

Figure 1 Place dialog box

Replace Selected Item option Preview option
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7. Click the page where you want to place the image.

The image is inserted into the page, at its current size. 
The image may overlap margins (Figure 2).

To minimize RAM use, InDesign displays images at a 
minimal quality by default.

8. To display the image at full quality, choose View > 
Display Performance > High Quality Display (Figure 3).

The image’s quality changes.

Note: This setting does not change how the image 
appears when printed.

9. Click the Selection tool in the Tools panel.

10. Click the image.

Observe that selection handles appear around the image, 
indicating that the image is in a graphics frame.

11. Choose Object > Select > Content.

This command selects the image inside the graphics 
frame.

12. Press the Delete key.

The image is deleted and the graphics frame sized to fit 
the image remains (Figure 4).

Figure 2 Image placed on page

Figure 3 Display performance options

Figure 4 Empty graphics frame

Placing images into graphics frames

Generally, you will want to create a graphics frame before placing an image. This gives you more control over the 
location of the image than when you place an image without first creating a frame.

To place an image into a graphics frame:

1. Select the Rectangle Frame tool in the Tools panel 
(Figure 5).

2.  Drag it across the page to create a graphics frame.

The frame is selected when you finish drawing it. 
Observe the selection handles at its edges.

3. Choose File > Place.

The Place dialog box appears (Figure 1).

4. Browse to the location of the file you want to place.

Figure 5 Tools panel

Rectangle 
Frame tool
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5. Make sure the Show Import Options option is deselected.

The Show Import Options option lets you manage 
advanced options for placed images. This option 
becomes more important when you place image formats 
such as Adobe Photoshop and Adobe Illustrator files.

6. Select the Preview option (Windows), and select the 
Replace Selected Item option.

When the Preview option is selected, a thumbnail of the 
image appears in the lower-right corner of the Place 
dialog box (Windows).

When you select the Replace Selected Item option, 
InDesign replaces whatever content is in the currently 
selected frame with your new image.

7. Select the file and click Open.

The image is added to the graphics frame.

If the image is larger than the frame, only a portion of the 
image appears (Figure 6).

8. Select Object > Fitting. 

This menu provides several options for fitting the content 
to the frame or the frame to the content (Figure 7).

If the new image is smaller or larger than the frame, you 
can refit the frame by choosing Object > Fitting > Fit 
Content To Frame. 

The content is fit to the placed frame (Figure 8).

Figure 6 Portion of image in frame

Figure 7 Object fitting options

Figure 8 Image fitted to frame

Add movies and sound files to documents

You import a movie or sound file by double-clicking and a media frame is automatically created. (If you drag to 
create the media frame, the movie boundary may appear cropped or skewed.) Movies and sound clips you add to a 
document can be played when the document is exported to an interactive Adobe PDF or HTML file.

To add a movie or a sound file:

1. Choose File > Place, and then double-click the movie or 
sound file. Click where you want the movie to appear.

When you place a movie or sound file, a media object 
appears in a frame (Figure 9). This media object links to 
the media file. You can resize the media object to 
determine the size of the play area.

If the center point of the movie appears outside the page, 
the movie is not exported.

Figure 9 Placed movie object
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2. Choose Window > Interactive > Media to open the Media 
panel to preview a media file (Figure 10). 

You can change the movie settings the Media panel: 

• Play On Page Load Play the movie when someone 
turns to the page on which the movie is located. If 
other page items are set to play on page load, use the 
Timing panel to determine the order.

• Loop Play the movie repeatedly. If the source file is a 
Flash Video format, looping works only in exported 
SWF files, not PDF files.

• Poster Specify the type of image that you want to 
appear in the play area. 

• Controller If the movie file is a Flash Video (FLV or 
F4V) file or an H.264-encoded file, you can specify 
prefabricated controller skins that let users pause, 
start, and stop the movie using a variety of methods. 
If you select Show Controller On Rollover, the 
controls appear when the mouse pointer hovers over 
the media object. Use the Preview panel to preview 
the selected controller skin. If the movie file is a 
legacy file (such as .AVI or .MPEG), you can choose 
None or Show Controller, which displays a basic 
controller that lets users pause, start, and stop the 
movie. SWF files you place may have their own 
controller skins. Use the Preview panel to test the 
controller options.

• Navigation Points To create a navigation point, 
advance the video to a specific frame, and then click 
the plus sign icon. Navigation points are useful when 
you want to play a video at a different starting point. 
When you create a button that plays a video, you can 
use the Play From Navigation Point option to play 
the video starting at any navigation point you add.

3. Choose File > Export.

The Export dialog box opens.

4. Specify a name and location for the file,

5. For Save As Type (Windows) or Format (Mac OS), 
choose Adobe PDF (Interactive), and then click Save.

The Export To Interactive PDF dialog box opens 
(Figure 11).

6. Review options in the Export To Interactive PDF dialog 
box, and then click OK. 

Figure 10 Media panel

Figure 11 Export To Interactive PDF dialog box
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How to create interactive documents
You can use Adobe InDesign to create dynamic web content or interactive documents. InDesign supports export to 
web-ready HTML or interactive PDF. 

Interactive web documents

When you generate a web-ready file, it is exported as an HTML page that plays back a SWF file. For SWF files, you 
specify the page size according to monitor resolution (such as 800x600). An exported SWF file is ready for viewing 
in Adobe Flash Player and may include interactive elements such as page transitions, hyperlinks, and navigation 
buttons.

In this guide, you will learn how to create web documents by using InDesign (Figure 1). Steps include how to create 
an interactive button, how to add a page transition, and how to export to SWF format. InDesign includes many more 
options for adding interactivity to your web document. Once you are comfortable with the basics, try experimenting 
with additional features such as rollover and click states for buttons, animating objects by using animation motion 
presets, and modifying the export SWF and HTML options.

Figure 1 Create interactive documents by using InDesign

Document in InDesign before SWF export

Interactive SWF file in web browser
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How to use styles, lists, columns and table of contents
Whether you’re working with long or short documents, styles can help you keep text formatting consistent. Styles are 
a collection of text attributes you can save and apply to new text. A consistent design, especially in longer documents, 
helps readers navigate through your document and also helps maintain a clean, appealing style and design layout.

Adobe InDesign has two kinds of styles:

• Character styles collect information about the way textual characters appear: font size, font family, font 
style (bold, italic), tracking, and leading. Access by choosing Window > Styles > Character Styles. 

• Paragraph styles include everything in character styles and also information about text orientation 
(horizontal and vertical), tab stops, and other paragraph attributes. You can apply a paragraph style to one 
paragraph or a range of paragraphs. Access by choosing Window > Styles > Paragraph Styles.

Use character styles only when you know you will be applying styles to a few words rather than to the whole 
paragraph. Otherwise, paragraph styles are generally more versatile.

Other common text features you may use in laying out InDesign documents will be bulleted and numbered list styles, 
using columns to format paragraphs, and including a table of contents.

This guide covers the following topics:

• Creating paragraph styles based on existing formatting and from scratch

• Applying and editing paragraph styles

• Creating and applying character styles

• Creating bulleted and numbered list styles

• Applying columns in a text frame

• Adding a table of contents to the first page of a document

Creating styles based on existing formatting

One of the easiest and fastest ways to create a style is to base it on text you have already formatted. This way, you can 
see how the text appears on the page before saving the text attributes as a style.

To create a style based on existing formatting:

1. Start InDesign, create a new document, and create a text 
frame by using the Type tool.

2. Add text to the text frame and apply formatting.

The text in the example (Figure 1) has the following 
formatting:

• Font family: Copperplate Gothic Bold

• Font size: 36 points

• Font color: Red

3. Select the text by using the Type tool.

4. Choose Window > Styles > Paragraph Styles to display 
the Paragraph Styles panel (Figure 1).

Figure 1 Paragraph Styles panel

Create New Style Panel menu
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5. With text still selected, click the Create New Style button 
at the bottom of the Paragraph Styles panel.

The new style appears in the Paragraph Styles panel 
(Figure 2).

6. Select the style and choose Style Options from the 
Paragraph Styles panel menu (Figure 3).

The Paragraph Style Options dialog box appears 
(Figure 4).

7. In the Style Name text box, enter a name for the style.

You will later use this name to apply the style, so make 
the name as meaningful as possible.

For example, you might name the style after its function 
(First-Level Heading) or its appearance (Copperplate, 
36pt, Red).

8. Click OK to close the Paragraph Style Options dialog 
box.

The renamed style is now available in the Paragraph 
Styles panel (Figure 5).

Figure 2 New style created in the Paragraph 
Styles panel

Figure 3 Paragraph Styles panel menu

Figure 4 Paragraph Style Options dialog box

Figure 5 Style renamed
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Creating a style from scratch

There may be a specific look and feel for a character or paragraph style you want to achieve. If so, you can create a 
custom style. 

To create a custom style:

1. If the Paragraph Styles panel is not open, choose Window 
> Styles > Paragraph Styles to display it.

2. Choose New Paragraph Style from the Paragraph Styles 
panel menu (Figure 3).

The New Paragraph Style dialog box appears (Figure 6).

3. In the Style Name text box, enter a name for the style.

You will later use this name to apply the style, so make 
the name as meaningful as possible. 

For example, you might name the style after its function 
(Second-Level Heading) or its appearance (Tahoma, 
18pt, blue).

4. In the General category of the New Paragraph Styles 
dialog box (which appears by default), you can set the 
following options:

• In the Based On pop-up menu, choose a style on 
which to base the current style. If you base this style 
on an existing style, all changes made to the “base” 
style—known as the parent style—will affect the 
new style—known as the child style. For more 
information on parent and child styles, see InDesign 
Help.

• In the Next Style pop-up menu, you can designate a 
style to follow the style you’re defining. If you set 
this option, the next style will automatically be 
applied to the next paragraph after you press Enter 
(Windows) or Return (Mac OS) at the end of a 
paragraph to which the style has been applied. For 
example, many headings are followed by “normal” 
or “body text” styles. If you set a style called “body 
text” as the next style for a heading, body text will be 
applied automatically when you press Enter or 
Return (Figure 7).

Figure 6 General category of New Paragraph Style 
dialog box

Figure 7 Next style
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5. Click other categories on the left side of the New 
Paragraph Style dialog box to set attributes in other 
categories.

For example, you might make changes in the following 
categories:

• Basic Character Formats: Font family, font size, 
font style, kerning, leading, tracking, case, and so on.

• Advanced Character Formats: Horizontal and 
vertical scale, baseline shift, and skew.

• Indents And Spacing: Text indent, space after text, 
alignment, and so on. Use the Align To Grid option 
to align all text to the document grid.

• Character Color: Sets character color from a list that 
includes any swatches you have created.

6. When you are satisfied with your changes, click OK to 
create the style.

The New Paragraph Style dialog box closes and the new 
style is available in the Paragraph Styles panel.

Applying a style

Once you create a style by using any method, you can apply that style to new or existing text.

To apply a style:

1. Create a text frame by using the Type tool.

2. Add text to the text frame.

3. If the Paragraph Styles panel is not open, choose Window 
> Styles > Paragraph Styles to display it.

4. Select the text by using the Type tool (Figure 8).

5. In the Paragraph Styles panel, click a style to apply it.

6. Click anywhere to deselect the text.

The style’s formatting has been applied to the text 
(Figure 9). Figure 8 Selecting the text to apply a style

Figure 9 Style applied
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Editing a style

Even after you apply a style to text, you can make changes to the style. These changes are applied automatically to all 
text with that style applied.

To edit a style:

1. If the Paragraph Styles panel is not open, choose Window 
> Styles > Paragraph Styles to display it.

2. Click a style to select it.

Ideally, this should be a style you have previously applied 
to text

3. Choose Style Options from the Paragraph Styles panel 
menu (Figure 3).

The Paragraph Style Options dialog box appears 
(Figure 10).

4. On the left side of the Paragraph Style Options dialog 
box, click the Basic Character Formats option to expand 
the Basic Character Formats category.

5. Change some of the following attributes:

• Font family

• Font size

• Case

• Leading

6. Click OK to apply the changes.

Any text with the style applied has changed.

The text in the example (Figure 11) has been changed to 
the following:

• Font family: Times New Roman

• Font size: 18 points

• Case: Small Caps

Figure 10 Paragraph Style Options dialog box

Figure 11 Style edits applied

Basic Character Formats category
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Creating and applying character styles

Character styles can include only those attributes you can apply to characters. Character styles are useful when you 
want to apply special formatting to a word or phrase within a paragraph—even a paragraph that has a paragraph style 
applied to it. Character styles override paragraph styles.

To create a character style:

1. Choose Window > Styles > Character Styles to display 
the Character Styles panel (Figure 12).

2. Choose New Character Style from the Character Styles 
panel menu (Figure 13). 

The New Character Style dialog box appears 
(Figure 14). 

The set of options on the left side is more limited than in 
the New Paragraph Style dialog box.

3. In the Style Name text box, enter a name for the new 
character style. 

You will later use this name to apply the style, so make 
the name as meaningful as possible. 

For example, you might name the style after its function 
(Text Highlight) or its appearance (Tahoma 14 pt Red).

4. Click categories on the left side of the dialog box to set 
attributes in other categories. 

For example, you might make changes in the following 
categories:

• Basic Character Formats: Font family, font size, 
font style, kerning, leading, tracking, case, and so on.

• Advanced Character Formats: Horizontal and 
vertical scale, baseline shift, and skew.

• Character Color: Sets character color from a list that 
includes any swatches you have created. 

5. When you are satisfied with your changes, click OK to 
create the character style

Figure 12 Character Styles panel 

Figure 13 Character Styles panel menu

Figure 14 New Character Style dialog box
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To apply a character style:

1. Create a text frame by using the Type tool.

2. Add text to the text frame. 

3. If the Character Styles panel is not open, choose Window 
> Styles > Character Styles to display it. 

4. Select one or two words of the text by using the Type tool 
(Figure 15). 

5. In the Character Styles panel, click the style to apply it. 

6. Click anywhere to deselect the text.

The style’s formatting has been applied to the selected 
text (Figure 16).

The style is not automatically applied to the entire 
paragraph as it is when you apply a paragraph style.

Figure 15 Applying a character style

Figure 16 Character style applied

How to create bulleted and numbered list styles

In bulleted lists, each paragraph begins with a bullet character. In numbered lists, each paragraph begins with an 
expression that includes a number or letter and a separator such as a period or parenthesis (Figure 17). The numbers 
in a numbered list are updated automatically when you add or remove paragraphs in the list. You can change the type 
of bullet or numbering style, the separator, the font attributes and character styles, and the type and amount of indent 
spacing.

A quick way to create a bulleted or numbered list is to type the list, select it, and then click the Bulleted List or 
Numbered List button in the Control panel. These buttons let you turn the list on or off and switch between bullets 
and numbers. You can also make bullets and numbering part of a paragraph style and construct lists by assigning 
styles to paragraphs.

Figure 17 Bulleted list (left) and numbered list (right)
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How to format a bulleted or numbered list:

1. Using the Type tool, select the set of paragraphs that will 
become the list (Figure 18), or click to place the insertion 
point where you want the list to begin.

2. Click the Bulleted List button or the Numbered List 
button in the Control panel (in Paragraph mode) 
(Figure 19). 

The selected text is formated (Figure 20).

3. To reformat bulleted or numbered paragraphs, use the 
Type tool to select the text.and choose Bullets And 
Numbering from the Control panel menu (in Paragraph 
mode)

4. In the Bullets And Numbering dialog box(Figure 21), do 
any of the following:

• Change the bullet character.

• Change the numbered list options.

• Choose a style for the numbers or bullets from the 
Character Style list.

To change the position of the bullet or number, specify 
any of the following:

• Alignment Left-aligns, centers, or right-aligns the 
bullets or numbers within the horizontal space 
allotted for numbers.

• Left Indent Specifies how far the lines after the first 
line are indented.

• First Line Indent Controls where the bullet or 
number is positioned.

• Tab Position Activates the tab position to create 
space between the bullet or number and the start of 
the list item.

Figure 18 Selected text

Figure 19 Control panel

Figure 20 Text reformatted into Numbered list

Figure 21 Bullets and Numbering dialog box

Numbered ListBulleted List Control panel 
menu
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How to create columns in a text frame 

You can use Text Frame Options to change settings such as the number of columns in a text frame, the vertical 
alignment of text within the frame, or the inset spacing, which is the distance of the margins between the text and the 
frame.

You can also make a paragraph span across multiple columns in a text frame to create a straddle head effect 
(Figure 22). You can choose whether a paragraph spans all columns or a specified number of columns. When a 
paragraph is set to span across columns in a multicolumn text frame, any text before the spanning paragraph becomes 
balanced as a result. You can also split a paragraph into multiple columns within the same text frame (Figure 22).

Figure 22 A heading that spans two columns (left) and a paragraph split into two column (right)

How to add columns to a text frame:

1. Using the Selection tool, select a frame, or using the Type 
tool, click inside the text frame or select text.

2. Choose Object > Text Frame Options.

The Text Frame Options dialog box opens (Figure 23).

3. Use the Number field to specify the number of columns. 
You can also set the width of each column, and the 
spacing between each column (gutter) for the text frame.

Figure 23 Text Frame Options dialog box
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4. (Optional) Select Balanced Columns to make text even at 
the bottom of a multi-column text frame (Figure 24).

5. Click OK to close the Text Frame Options dialog box.

Figure 24 Before and after balancing columns

How to span a paragraph across columns:

1. Use the Type tool to select text the paragraph that you 
want to span across columns (Figure 25).

2. Choose Type > Paragraph.

The Paragraph panel opens (Figure 26).

3. Choose Span Columns from the Paragraph panel menu.

The Span Columns dialog box opens.

4. Choose Span Columns from the Paragraph Layout menu.

The Span Columns settings are available (Figure 27).

5. Choose the number of columns you want the paragraph 
to span from the Span menu. Choose All if you want the 
paragraph to span across all the columns.

6. (Optional) To add extra space before or after the span 
paragraph, specify Space Before Span and Space After 
Span values.

7. Click OK to close the Span Columns dialog box.

The selected text spans across indicated columns 
(Figure 28).

Figure 25 Selected text

Figure 26 Paragraph panel

Figure 27 Span Columns dialog box

Figure 28 Heading spanning two columns

Panel menu
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How to split a paragraph into columns:

1. Use the Type tool to select text the paragraph that you 
want to span across columns (Figure 29).

2. Choose Type > Paragraph.

The Paragraph panel opens (Figure 26).

3. Choose Span Columns from the Paragraph panel menu.

The Span Columns dialog box opens.

4. Choose Split Columns from the Paragraph Layout menu.

The Split Columns settings are available (Figure 30).

5. (Optional) Specify the following options as needed:

• Sub-columns Choose the number of columns you 
want the split the paragraph into.

• Space Before Split / Space After Split Add space 
before or after the split paragraph.

• Inside Gutter Determine the space between the split 
paragraphs.

• Outside Gutter Determine the space between the 
outside of the split paragraphs and the margins.

6. Click OK to close the Span Columns dialog box.

The selected text spans across indicated columns 
(Figure 31).

Figure 29 Selected text

Figure 30 Span Columns dialog box

Figure 31 Paragraph spanning two columns

How to create a Table of Contents

A table of contents (TOC) can list the contents of a book, magazine, or other publication; display a list of illustrations, 
advertisers, or photo credits; or include other information to help readers find information in a document or book file. 
One document may contain multiple tables of contents—for example, a list of chapters and a list of illustrations.

Each table of contents is a separate story consisting of a heading and a list of entries sorted either by page number or 
alphabetically. Entries, including page numbers, are pulled directly from content in your document and can be 
updated at any time.

The process for creating a table of contents requires three main steps. First, create and apply the paragraph styles 
you’ll use as the basis for the TOC. Second, specify which styles are used in the TOC and how the TOC is formatted. 
Third, flow the TOC into your document.
© 2013 Adobe Systems Incorporated How to use styles, lists, columns and table of contents 11
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Generate a table of contents

Before you generate a table of contents, you will have already created a multi-page layout with chapter titles, section 
headings, and other content. You must decide which paragraphs should be included in the table of contents (such as 
chapter titles and section headings), and then define paragraph styles for each. Make sure that these styles are applied 
to all appropriate paragraphs in the document.

When you generate the table of contents, you can also use custom paragraph and character styles to format the table 
of contents (Figure 32). 

Figure 32 Table of contents without paragraph styling (left) and with paragraph styling applied to entries (right) 

How to generate a table of contents:

1. If you’re creating a table of contents for a single 
document, you will want to add a new page at the 
beginning of the document. Choose Layout > Pages > 
Insert Pages.

The Insert Pages dialog box opens (Figure 33).

2.  In the Insert menu, select Before Page, and confirm the 
page number text box is set to page 1.

3. Click OK to close the Insert Pages dialog box.

The new page is added to the layout, this is where you 
will be placing your table of contents.

4. Choose Layout > Table Of Contents.

The Table of Contents dialog box opens (Figure 34)

Figure 33 Insert Pages dialog box

Figure 34 Table of Contents dialog box
How to use styles, lists, columns and table of contents © 2013 Adobe Systems Incorporated

This document requires Adobe InDesign CC, June 2013. Technical instructions may differ depending on your version.



Adobe InDesign Guide
5. In the Title box, type a title for your TOC (such as 
Contents or List of Figures). This title will appear at the 
top of the table of contents. To format the title, choose a 
style from the Style menu. For example, in Figure 35 the 
default TOC Title option is selected.

6. Determine which content you want to include in the table 
of contents by selecting paragraph styles in the Other 
Styles list and clicking the Add button to move the 
selection to the Include Paragraph Styles list (Figure 36).

Next, you need to define how the selected Paragraph 
Styles will be formatted in the TOC. 

7. Select the first item in the Included Paragraph Styles list. 

The selected style appears in the Style area of the Table 
of Contents dialog box (Figure 37). 

8. Set the Entry Style for the selected paragraph style. For 
example, in Figure 37, the Section Heading Entry Style 
is set to the default TOC Body Text.

9. Repeat setting Entry Style for each of the items in the 
Included Paragraph Styles list.

10. Click OK to close the Table of Contents dialog box.

The table of contents is generated, but the entries still 
need to be styled with dots or tab leaders separating the 
entry from its associated page number (Figure 38). 

Figure 35 Style menu

Figure 36 Including styles in the Table of Contents

Figure 37 Setting Entry Style for selected 
Paragraph Styles

Figure 38 Generated table of contents
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How to create TOC entries with tab leaders:

1. Choose Window > Styles > Paragraph Styles to display 
the Paragraph Styles panel (Figure 39). 

2. Double-click the Paragraph Style you used for the body 
entries of the TOC. For example, in the previous section, 
you used the TOC Body Text to style all TOC entries.

The Paragraph Style Options dialog box opens 
(Figure 40).

3. Click Tabs.

4. Select the right-justified tab icon, and then click on the 
ruler to position the tab stop (Figure 41).

5. For Leader, type a period (.).

6. Click OK to close the Paragraph Style Options dialog 
box. 

The table of contents paragraph style is reformatted with 
a tab leader (Figure 42).

Next, the entry levels need to be refined so that the 
heading levels are indented from each other.

Figure 39 Paragraph Styles panel

Figure 40 Paragraph Style Options dialog box

Figure 41 Tabs section of Paragraph Style Options

Figure 42 Table of contents with tab leader

Panel menu

Right-Justified Tab Click on ruler to place tab
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7. In the Paragraph Styles panel, select the style you used 
for your TOC entries (Figure 39).

8. Choose Duplicate Style from the Paragraph Styles panel 
menu.

The Duplicate Paragraph Style dialog box opens 
(Figure 43).

9. Rename the style in the Style Name text box. For 
example, consider defining the level of the entry for 
which the style is named. In this example, the Style name 
is changed to TOC Body Text level 2.

10. Click Indents and Spacing.

11. Click the Left Indent up arrow or enter a dimension in the 
number box to add space to the left-hand margin of the 
style (Figure 44).

12. Click OK to close the Duplicate Paragraph Style dialog 
box.

13. Choose Layout > Table Of Contents.

The Table of Contents dialog box opens.

14. In the Include Paragraph Styles area, choose the style that 
you want to update with the redefined indented style.

15. In the Style area, select the just-created paragraph style to 
define the Entry Style (Figure 45).

Figure 43 Duplicate Paragraph Styles dialog box

Figure 44 Paragraph Style Options dialog box

Figure 45 Setting the Entry Style for a second-
level heading
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16. Click OK to close the Table Of Contents.

The second level heading in the table of contents is 
updated (Figure 46).

17. Repeat steps 7 to 16 to redefine any third or fourth level 
entry styles you have listed in your table of contents. 
Consider adding additional formatting to the styles such 
as increased indentation and italics to create visual 
differentiation among the levels (Figure 47).

Figure 46 Updated TOC second-level heading

Figure 47 Updated TOC third-level heading

Update and edit a table of contents

The table of contents is like a snapshot of content in your document. If page numbers in your document change, or if 
you edit headings or other elements associated with table of contents entries, you’ll need to regenerate the table of 
contents to update it.

How to update a table of contents:

1. Select or place the insertion point in the text frame containing the table of contents, and then choose Layout > 
Update Table Of Contents.

2. If you have multiple tables of contents in your document, such as a list of figures and a list of tables, select the 
text frame containing a different list, and then choose Layout > Update Table Of Contents.
How to use styles, lists, columns and table of contents © 2013 Adobe Systems Incorporated
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Consider the following factors when designing your InDesign document for SWF and HTML output.

Document setup factors

• How InDesign pages are converted When you export to SWF, InDesign spreads become separate clips in a 
timeline, like slides in a slide show. Each spread is mapped to a new keyframe. In Flash Player, you advance 
through the spreads of the exported document by pressing arrow keys or clicking interactive buttons.

• Page size When you create a document, you can choose a specific resolution, such as 800x600, from the 
Page Size menu in the New Document dialog box. During export, you can also adjust the scale or resolution 
of the exported SWF file.

Conversion factors

• Color SWF files use RGB color. When a document is exported to SWF, InDesign converts all color spaces 
(such as CMYK and LAB) to sRGB. InDesign converts spot colors to equivalent RGB process colors. To 
avoid unwanted color changes in artwork with transparent text choose Edit > Transparency Blend Space > 
Document RGB. To avoid unwanted color changes in images with transparency, avoid using a lossy 
compression during export.

• Text When exporting to SWF, you can determine whether to output text as Flash text or convert it to outlines 
or pixels. Text exported as Flash Classic Text remains fully searchable in web browsers when saved as SWF 
files.

• Images When you export images to SWF, you can change image compression, JPEG quality, and resolution 
settings during export.

• Transparency Before exporting to SWF, make sure that transparent objects do not overlap any interactive 
element, such as a button or hyperlink. If an object with transparency overlaps an interactive element, the 
interactivity may be lost during export. In some instances, choosing a lossy compression reduces the quality 
of images with transparency. When exporting, choose PNG (Lossless) to improve the quality.

Interactivity factors

You can include buttons, page transitions, hyperlinks, animation, and media files in exported SWF files.

• Buttons For buttons in an exported SWF file, the Next Page and Previous Page actions are especially useful 
controls for playback in Flash Player. However, some actions that work in interactive PDF files have no 
effect in Flash Player. When you choose an action in the Buttons panel, do not select an option from the PDF 
Only section.

• Page Transitions All page transitions work well in Flash Player. In addition to page transitions that appear 
when you turn the page, you can add an interactive page curl during export that lets you drag corners of 
pages to turn them.

• Hyperlinks Create links to websites or to other pages in the document. 

• Movies and sound clips Movies and sound clips are included in an exported SWF file if they’re in SWF 
format for movies and MP3 format for sound clips.
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To create interactive files for the web:

1. Start InDesign and choose File > New > Document.

The New Document dialog box appears (Figure 2).

2. When creating a document intended for the web, choose 
Web from the Intent menu in the New Document dialog 
box.

3. Enter 2 or more pages in the Number Of Pages box.

4. Choose the default 800 x 600 from the Page Size menu.

5. Click OK to close the New Document dialog box.

First, you need to create an interactive button that allows 
users to move from page to page in the exported SWF 
file. 

6. Import an image, draw a shape, or add text to the 
document.

7. Use the Selection tool (Figure 3) to select the image, 
shape, or text frame that you want to convert to a button.

8. Choose Window > Interactive > Buttons And Forms. 

The Buttons And Forms. panel appears (Figure 4).

Note: Sample buttons are also available. Click the 
Buttons And Forms panel menu to access the Sample 
Buttons And Forms panel (Figure 5), and scroll down for 
buttons. You can drag predefined navigation buttons and 
form elements into your document and attach actions to 
these instead of an existing image, shape, or text frame in 
the document.

9. Click the Convert To Button icon in the Buttons And 
Forms panel (Figure 4).

The object is converted to a button and the Buttons And 
Forms panel is updated.

10. Name the new button in the Name text box and confirm 
that the Hidden Until Triggered option is not selected.

Next, you need to define the mouse event and assign an 
action for the button. 

Figure 2 New Document dialog box

Figure 3 Tools panel

Figure 4 Buttons And Forms panel

Figure 5 Sample Buttons and Forms panel

Intent menu

Selection tool

Panel menu

Convert To 
Button 
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11. Click the Event menu, and select from the available 
options (Figure 6). An event defines how actions are 
activated.

• On Release Or Tap When the button is released after 
a click or a tap. This is the most commonly used 
event, because it gives the user one last chance to 
drag the cursor or touch off the button and not 
activate the action.

• On Click When the button is clicked (without being 
released). Unless you have a specific reason for 
using On Click, it’s preferable to use On Release so 
that users have a chance to cancel the action.

• On Roll Over When the mouse pointer or touch 
action enters the button area defined by the button’s 
bounding box.

• On Roll Off When the mouse pointer or touch action 
exits the button area.

12. Click the Add New Action button, and choose an action 
to assign to the event you just selected. 

For example, if you are working with a multipage spread, 
you might choose Go To Next Page from the list of 
destination options (Figure 7).

If you choose Go To URL, specify the web page address. 
Some actions, such as Go To Next View, do not have 
additional settings.

13. With the object still selected, choose Window > 
Interactive > Page Transitions to add page transitions 
such as wipes or dissolves. 

The Page Transitions panel appears (Figure 8).

14. From the Transition menu, select Page Turn (SWF Only).

You can move your mouse over the Preview area to see 
how the transition works.

15. Choose File > Save.

16. To export the document to SWF format, choose File > 
Export. 

The Export dialog box appears.

Figure 6 Event menu

Figure 7 Add New Action menu

Figure 8 Page Transitions panel

Event 
menu

Add New 
Action button

Preview area

Transition menu
How to create interactive documents © 2013 Adobe Systems Incorporated

This document requires Adobe InDesign CC, June 2013. Technical instructions may differ depending on your version.



Adobe InDesign Guide
17. Choose Flash Player (SWF) from the Save As Type 
(Windows) or Format (Mac OS) menu, and click Save.

The Export SWF dialog box appears (Figure 9).

You can specify the export options in the Export SWF 
dialog box. 

For this example, accept the default export options. For 
more information about Export SWF options, see “SWF 
export options” in InDesign Help.

18. Confirm the Generate HTML File option is selected.

With this option selected, an HTML page is generated 
that plays back the SWF file. This option is especially 
useful for quickly previewing the SWF file in your web 
browser.

19. Click OK. 

The Generate Flash Player (SWF) progress dialog box 
appears and the file is processed.

The file opens in your default browser. 

20. Test the button interactions in your interactive SWF file 
(Figure 10).

Figure 9 Export SWF dialog box

Figure 10 Testing hyperlinks in the browser
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Animation

You can use Animation effects to make objects move in InDesign documents you export as SWF files. For example, 
you can apply a motion preset to drop a heading in from the top or to make an image of an automobile appear to move 
in from the right side of the screen and screech to a halt (Figure 11). Use the following tools and panels to animate 
documents.

• Animation panel Apply a motion preset and edit settings such as duration and speed.

• Direct Selection tool and Pen tool Edit the path on which the animated object travels.

• Timing panel Determine the order in which objects on a page are animated.

• Preview panel View the animation in an InDesign panel.

Figure 11 Examples of animation options

For more detailed information about how to use animation in InDesign, refer to InDesign Help.

Animating a document with motion presets

Motion presets are pre-made animations that you can apply to objects quickly. Use the Animation panel to apply 
motion presets and change animation settings such as duration and speed. The Animation panel also lets you specify 
when an animated object plays.

These motion presets are the same as those found in Adobe Flash Professional. You can import any custom motion 
preset created in Flash Professional, and you can save motion presets you create and edit for sharing with others.

Note: Animation features are supported only when exporting to Adobe Flash Player (SWF). They are not supported 
when exporting to Interactive PDF. To add animation effects to a PDF file, export a selection as a SWF file from 
InDesign and place that SWF file in the InDesign document.

Page title drops in 
from the top

Automobile moves in 
from the right and 
stops
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Motion preset options

Motion preset options appear in the Animation panel (Figure 12). To display the Animation panel, choose Window > 
Interactive > Animation. Click the disclosure triangle beside Properties to display advanced settings.

• Name Specify a name for the animation. Descriptive names are especially useful when setting up an action 
that triggers the animation.

• Preset Choose from a list of predefined motion settings.

• Event(s) By default, On Page Load is selected, which means the animated object plays when the page opens 
in the SWF file. Choose On Page Click to trigger the animation when readers click the page. Choose On 
Click (Self) or On Roll Over (Self) to trigger the animation when readers click the object or move the mouse 
over it. If you create a button action that triggers the animation, On Button Event is selected.  You can 
specify multiple events to start the animation. If you select the On Roll Over (Self) event, you can also select 
Reverse On Roll Off. This option reverses the action of the animation when the mouse moves off the object.

• Create Button Trigger Click this button to trigger the animation from an existing object or button. After you 
click Create Button Trigger, click the object that triggers the animation. The object is converted to a button, 
if necessary, and the Buttons panel appears.

• Duration Specify how much time it takes for the animation to occur.

• Play Specify the number of times the animation is played, or select Loop to cause the animation to play 
repeatedly until it’s stopped.

• Speed Choose an option to determine whether the animation speed is a steady rate (None), starts slowly and 
speeds up (Ease In), or slows down at the end (Ease Out). 

Figure 12 Animation panel

Preset preview

Preset menu

Animate 
options 

Events menu

Create Button Trigger 
button

Animation panel menu

Animation proxy
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The following options are available when Properties is expanded (Figure 12).

• Animate Choose one of the following settings from the Animate menu. Each setting is illustrated in the 
example (Figure 13).

◦ From Current Appearance uses the object’s current properties (scale percentage, rotation angle, and 
position) as the starting point of the animation. 

◦ To Current Appearance uses the object’s properties as the ending point of the animation. This option is 
especially useful in slide shows. For example, objects that fly in from off the page can appear on the 
page rather than on the pasteboard, improving the appearance of the printed document. 

◦ To Current Location uses the current object’s properties as the starting point of the animation and the 
object’s position as the ending point. This option is similar to From Current Appearance, except that the 
object finishes in its current location and the motion path is offset. This option is especially useful for 
certain presets, such as blurs and fades, to prevent the object from appearing in an undesirable state at 
the end of the animation. 

Figure 13 Animate settings

Note: To display the proxy at the end of the motion path, click the Show Animation Proxy at the bottom of 
the Animation panel. A proxy is the visual representation of the object at the end of a motion path.

• Rotate Specify a rotation angle that the object completes during the animation.

• Origin Use the proxy to specify the origin point of the motion path on the animated object.

• Scale Specify a percentage value to determine whether the object increases or decreases in size during 
playback.

• Opacity Choose an option to determine whether the animation remains solid (None), gradually becomes 
visible (Fade In), or gradually becomes invisible (Fade Out).

• Visibility Select Hide Until Animated or Hide After Animating to make an object invisible before or after 
playback.

To animate a document with motion presets:

1. Place the object you want to animate in your document.

2. Choose Window > Interactive > Animation.

The Animation panel appears (Figure 12).

Object and path before 
animation

From Current Appearance To Current Appearance To Current Location

Proxy
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3. Choose a motion preset from the Preset menu, such as 
Fly In From Right.

A green motion path appears, indicating the start, finish, 
and travel path of the object (Figure 14).

4. Specify other motion preset options such as Event(s), 
Duration, Play, and Speed.

5. To edit the motion path, use the Pen tool and Direct 
Selection tool.

6. (Optional) If you place more than one object in the 
document, use the Timing panel (Window > Interactive > 
Timing) to determine the order of when animated objects 
play (Figure 15).

For example, you can change one set of animations that 
occur when the page is loaded, and then change another 
set of animations that occur when the page is clicked.

Animated objects are listed in the order they were 
created. Animations listed for the Page Load event occur 
sequentially by default. Animations listed for the Page 
Click event are played in sequence each time the page is 
clicked.

7. Choose Window > Interactive > SWF Preview to preview 
the animation in InDesign (Figure 16).

8. If you made changes to the motion preset and you want to 
save the custom preset for other uses, choose Save from 
the Animation panel menu.

Note: You can also delete, duplicate, import, or export 
motion presets from the Animation panel menu.

9. Type a name for the preset and click OK.

Figure 14 Motion path

Figure 15 Timing panel

Figure 16 SWF Preview panel

Interactive PDF documents

Creating an interactive PDF document is a good way to create an dynamic slide show. As with interactive SWF 
documents, you can create interactive PDF documents with buttons, movies and sound clips, hyperlinks, bookmarks, 
and page transitions. You can also set up documents in InDesign and convert them to forms in Acrobat. 

In this guide you will learn how to create dynamic PDF documents by using InDesign. Steps include how to create a 
bookmark, insert a URL link, apply a decorative page transition, and export to PDF format. Once you are familiar 
with the basics, try adding movies and sound clips into your dynamic PDF document.

Play 
preview

Clear 
preview
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Create interactive documents for PDF

You can export Adobe PDF documents that include the following interactive features.

• Bookmarks Bookmarks you create in the InDesign document appear in the Bookmarks tab on the left side of 
the Adobe Acrobat or Adobe Reader window. Each bookmark jumps to a page, text, or graphic in the 
exported PDF file. 

• Movies and sound clips You can add movies and sound clips to a document, or you can link to streaming 
video files on the Internet. These movies and sound clips can be played back in the exported PDF file. 

• Hyperlinks In an exported PDF document, clicking a hyperlink jumps to another location in the same 
document, to a different document, or to a website. You can create hyperlinks to pages, URLs, text anchors, 
e-mail addresses, and files. If you create a hyperlink to a page or text anchor in a different document, make 
sure the exported files appear in the same folder.

• Cross-references A cross-reference refers readers from one part of your document to another in the exported 
PDF file. Cross-references are especially useful in user guides and reference manuals. When you export a 
document with cross-references to PDF, the cross-references act as interactive hyperlinks. 

• Page transitions Page transitions apply a decorative effect, such as a dissolve or wipe, when you turn the 
page in the exported PDF while in Full Screen mode.

To create an interactive document for PDF:

1. Start InDesign and choose File > New > Document.

The New Document dialog box appears.

2. When creating a document intended for printing, accept 
the default Print from the Intent menu in the New 
Document dialog box.

3. Enter 2 or more pages in the Number Of Pages box.

4. Choose Letter from the Page Size menu.

5. Click OK to close the New Document dialog box.

The first step is to create a bookmark to another section 
of the document. 

6. Choose Window > Interactive > Bookmarks. 

The Bookmarks panel appears (Figure 17).

7. Select text in your document. 

By default, the text you select becomes the bookmark 
label.

8. Do one of the following to create the bookmark:

• Click the Create New Bookmark button in the 
Bookmarks panel.

• Choose New Bookmark from the panel menu.

Figure 17 Bookmarks panel

Bookmarks 
panel menu

Create New 
Bookmark
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9. Accept the default bookmark name, or rename the 
bookmark.

Bookmarks appear in the Bookmarks navigation pane 
when you open the exported PDF file in Adobe Reader or 
Acrobat.

Note: You can use the Bookmarks panel menu to rename 
and delete bookmarks. Drag bookmarks in the panel to 
rearrange them. You can nest a list of bookmarks to show 
a relationship between topics. Nesting creates a parent/
child relationship. You can expand and collapse this 
hierarchical list as desired. Changing the order or nesting 
order of bookmarks does not affect the appearance of 
your actual document.

Next, you create a hyperlink that takes you to an external 
website destination.

10. Choose Window > Interactive > Hyperlinks.

The Hyperlinks panel appears (Figure 18).

11. Select the text, frame, or graphic you want to be the 
hyperlink’s source.

12. Do one of the following to create the hyperlink:

• Click the Create New Hyperlink button in the 
Hyperlinks panel.

• Choose New Hyperlink in the Hyperlinks panel 
menu. 

The New Hyperlink dialog box appears (Figure 19).

Note: Use the Hyperlinks panel menu to edit, delete, 
reset, or locate hyperlinks.

13. Choose URL from the Link To menu.

14. In the URL text box, type or paste the destination URL 
for the hyperlink.

15. Specify appearance options, such as the following:

Character Style Choose a character style to apply to the 
hyperlink source. The Character Style option is available 
only if the hyperlink source is selected text, not a selected 
frame or graphic.

Type Select Visible Rectangle or Invisible Rectangle.

Highlight Select Invert, Outline, Inset, or None. These 
options determine the appearance of the hyperlink when 
readers click it in the PDF file.

Color Select a color for the visible hyperlink rectangle.

Width Select Thin, Medium, or Thick to determine the 
thickness of the hyperlink rectangle.

Style Select Solid or Dashed to determine the appearance 
of the hyperlink rectangle.

Figure 18 Hyperlinks panel

Figure 19 New Hyperlink dialog box
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16. Click OK.

Note: If a URL hyperlink isn’t working in the exported 
PDF, the problem may be that the hyperlink is a shared 
destination. Double-click the hyperlink in the Hyperlinks 
panel, choose URL from the Link To menu, deselect 
Shared Hyperlink Destination, and click OK.

17. Choose File > Export.

18. Specify a name and location for the file.

19. For Save As Type (Windows) or Format (Mac OS), 
choose Adobe PDF (Interactive).

20. Click Save.

The Export To Interactive PDF dialog box appears 
(Figure 20).

21. Select the Open In Full Screen Mode option to ensure the 
interactive PDF fills the entire screen when it opens.

22. Click OK.

The Generating PDF progress dialog box appears and the 
file is processed.

The file opens in your default application for PDF files.

Note: If you are asked whether you want to view the 
document in Full Screen mode, click Yes.

23. Click anywhere in the PDF document to advance to the 
next page.

24. Test the hyperlinks you created (Figure 21).

Note: If you receive a warning that the document is 
trying to connect to a website, click Allow.

25. Close Full Screen mode by pressing Ctrl+L (Windows) 
or Command+L (Mac OS) or Esc.

26. To display the navigation pane in Adobe Acrobat or 
Adobe Reader, do one of the following:

• Click any panel button on the left side of the work 
area to display that panel.

• Choose View > Show/Hide > Navigation Panes > 
Show Navigation Pane.

27. Test the bookmarks you created (Figure 22).

Figure 20 Export To Interactive PDF dialog box

Figure 21 Testing hyperlinks in Acrobat

Figure 22 Bookmarks in the navigation pane in 
Acrobat
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How to prepare files for print
Preparing files for printing involves the following steps:

• Setting printer settings

• Using Preflight to confirm that the file has all components necessary for printing

• Packaging the files for printing

For more information on printing, see the Adobe Print Resource Center at www.adobe.com/go/print_resource. 

Printing to a printer

You set printer settings through the Adobe InDesign Print dialog box. In the following steps, you set printer settings 
and then print to your printer.

To print to a printer:

1. Start InDesign and open the document to be printed.

2. Select File > Print.

The Print dialog box appears (Figure 1) with the General 
area selected in the left pane.

3. Under Pages, select the pages you want to print.

4. Under Options, make sure Visible & Printable Layers is 
selected in the Print Layers menu.

This means everything you see in your InDesign 
document will print.

5. In the left pane, choose Setup.

The Setup area of the Print dialog box appears 
(Figure 2).

6. In the Paper Size menu, select Letter (Windows) or US 
Letter (Mac OS).

This the default size paper loaded in most printers. 
Alternately, you can select the dimensions of the paper in 
your printer.

Figure 1 Print dialog box, General area

Figure 2 Print dialog box, Setup area
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7. In the left pane, choose Marks And Bleed to display the 
Marks And Bleed area of the Print dialog box. 

8. Select the All Printer’s Marks option (Figure 3).

This tells InDesign to print all the marks that let you cut 
your document to the desired size. See Figure 5 for an 
example of marks.

Because printers do not print to the page edge, you will 
usually need to crop your document after printing. Crop 
marks show you where to cut your document.

9. Select Output in the left pane.

The Output area of the Print dialog box appears 
(Figure 4).

10. In Output settings, make sure Composite RGB is selected 
in the Color menu.

11. Leave the other settings unchanged, and click Print to 
print the document.

When the document prints, it shows all of the printer’s 
marks (Figure 5).

Figure 3 Print dialog box, Marks And Bleed area 

Figure 4 Print dialog box, Output area

Figure 5 Printed file with printer's marks

All Printer’s Marks option
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Sending files to a print vendor

Unlike your printer at home or school, print vendors have very specific requirements for what they will print. These 
requirements have been established to ensure the printed copies you receive look the way you expected. As you gain 
experience as a designer, you will find that meeting these requirements results in fewer problems with print vendors. 
After all, you’re paying a lot of money to get your designs printed.

Most print vendors accept print projects in one of two formats:

• PDF/X-1: A special kind of PDF that restricts PDF features (such as comments) that might interfere with the 
print process.

• Native files: The set of files you used to create your InDesign document. These include the InDesign file itself, 
any fonts used in the document, and any image files used in the document.

Preparing a PDF/X-1 for a print vendor

The PDF/X-1 file format is widely used by print vendors in the United States. PDF/X-1 is a PDF file that excludes 
everything that might interfere with producing a quality print job, such as RGB images, annotations, form fields, and 
comments. For more information, see www.pdfx.info/.

Note: Because PDF/X-1 excludes all RGB images, you need to be sure the images in your InDesign document are 
CMYK. It is best to convert images to CMYK TIFFs in Photoshop before placing them in an InDesign file.

To prepare a PDF/X-1 file:

1. Start InDesign and open the document you want to 
prepare for a print vendor.

2. Choose File > Export.

The Export dialog box appears (Figure 6).

3. Specify a name and location for the file.

4. Specify Adobe PDF (Print) in the Save As Type menu 
(Windows) or the Format menu (Mac OS).

5. Click Save.

The Export Adobe PDF dialog box appears (Figure 7).

6. From the Adobe PDF Preset pop-up menu, choose PDF/
X-1a:2001.

7. Leave other settings unchanged, and click Export.

A message will appear that shows you the progress of the 
export.

8. When the export is complete, browse to the location of 
the exported file and open the file. 

The PDF looks like any other PDF, without comments 
and other features.

9. Close the file without saving.

Note: Be careful not to save the exported document in 
Adobe Acrobat X. Saving the document could change the 
settings, meaning the document would no longer conform 
to the PDF/X-1a:2001 standard.

Figure 6 Export dialog box

Figure 7 Export Adobe PDF dialog box
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Sending native files to a print vendor

Some print vendors may require you to send native files to be printed. Native files consist of the following:

• The InDesign file for the project

• Any images used in the project

• Any fonts used in the project

To prepare native files, first check that all of the appropriate files are available, and then package these files in one 
folder to send to the print vendor.

Using Preflight

Use a feature of InDesign called Preflight to confirm that all graphics and fonts used in the file are available for 
printing.  Preflight is the industry-standard term for performing a quality check on the document.

While you edit your document, the Preflight panel warns of problems that can prevent a document or book from 
printing or outputting as desired. These problems include missing files or fonts, low-resolution images, overset text, 
and a number of other conditions.

To take advantage of live preflighting, create or specify a preflight profile in the early stages of creating a document. 
If Preflight is turned on, a red circle icon appears in the status bar when InDesign detects any problems. You can open 
the Preflight panel and view the Info section to get basic guidance for fixing the problems.

To use Preflight:

1. Double-click the Preflight icon at the bottom of the 
document window. The Preflight icon is green if no 
errors are detected or red (Figure 8) if errors are 
detected.

The Preflight panel appears.

For this print job Preflight encounters one missing image 
that appears in two places (Figure 9).

2. In this example, the Alice Ritter drawing image link is 
missing. Double-click the image file in the Preflight 
panel to help locate the broken link within the InDesign 
layout.

Figure 8 Preflight icon in document window

Figure 9 Error area of the Preflight panel

Image file
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3. Choose Window > Links.

The Links panel shows all images placed in the 
document. Broken links are flagged with a question mark 
symbol (Figure 10). 

4. In the example (Figure 10), the Alice Ritter drawing 
image is missing. To locate the image on your system, 
double-click the question mark icon.  

If the image is not on your system, you should copy the 
image to your system before continuing to prepare the 
package. Without the image file, your print vendor will 
not be able to print your document correctly.

The Locate dialog box appears (Figure 11).

5. In the Locate dialog box, browse to the location of the 
missing image.

6. Select the image and click Open.

The Locate dialog box closes.

7. Return to the Preflight panel and confirm that all 
preflight errors have been resolved.

Figure 10 Preflight Links and Images category

Figure 11 Locate dialog box

Packaging files for a print vendor

When you package a file, you collect into one folder all of the assets a print vendor will need to print the file. You 
could do this manually, but the Package utility in InDesign makes this process much easier.

To package a file:

1. Choose File > Package. (If Package does not appear in 
the File menu, try choosing a different workspace, such 
as Window > Workspace > Advanced.)

The Summary area of the Package dialog box appears 
(Figure 12). An alert icon indicates any problem areas.

Figure 12 Package dialog box, Summary area

Alert icon
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2. If you're notified of problems in the Package dialog box, 
do one of the following:

• Click Cancel, and use the Preflight panel to resolve 
problem areas.

• In the left pane, click the problem area (such as 
Fonts) and then correct the problem. When you’re 
satisfied with the document, begin the packaging 
process again.

3. When there are no problems, click Package in the 
Package dialog box to begin packaging.

The Printing Instructions dialog box opens (Figure 13).

4. Fill in the printing instructions. The filename you type is 
the name of the report that accompanies all other 
packaging files. Enter the following information:

• Your contact information, including company, 
address, email, and phone number.

• Any instructions for printing, such as number of 
copies or when the print vendor should call you.

5. Click Continue.

The Printing Instructions dialog box closes.

The Package Publication (Windows) or Create Package 
Folder (Mac OS) dialog box appears (Figure 14).

6. Select the following options:

• Copy Fonts

• Copy Linked Graphics

• Update Graphic Links In Package

7. In the Package Publication dialog box, browse to a folder 
for the packaged document.

8. Click Package.

A dialog box appears warning you about copying fonts. 
Many font companies, such as Adobe, let you send a 
copy of your font to the printer. Check your font license 
to be sure.

Although most print vendors will have a copy of the font 
you’re using, you send them the font to make sure it’s the 
correct one.

9. Click OK in the Warning dialog box.

InDesign creates the document package.

Figure 13 Printing Instructions dialog box

Figure 14 Package Publication dialog box
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10. Close or minimize InDesign. Navigate to the folder on 
your system where you placed the package (Figure 15).

The folder contains an INDD file, a text file with your 
instructions, a Font folder, and a Links folder.

11. Open the Links folder.

You should see files for the images you’ve included in 
the document.

You can now submit the package to a print vendor. 

Figure 15 Folder containing print package
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How to export for multiple screens
You can use the Articles panel (Figure 1) to manage the 
sequence of text, images, and graphics for export to multiple 
screens without changing your InDesign layout. Organize 
your content by dragging it into the Articles panel to define 
the export order for publishing digital documents. Two output 
formats for digital documents are covered in this guide: 

• Digital Editions (EPUB) Export a document or book 
as a reflowable XHTML-based eBook that is 
compatible with the Adobe Digital Editions reader 
software and other EPUB readers.

• HTML5 Export your InDesign layout, including 
formatting and interactivity, to HTML5, enabling 
you to preview and export content for modern tablet 
devices without writing code.

Figure 1 Articles panel

Articles panel

Articles provide an easy way to create relationships among page items. You can use these relationships to define the 
content you want to export to EPUB, HTML, or Accessible PDFs and to define the order of the content. You can 
create articles from a combination of existing page items within a layout, including images, graphics, and text. Once 
you create an article, you can add, remove, or reorder page items. You can create articles manually by dragging one or 
more page items to an article in the Articles panel.

You can also add bulk content to an article. You can add selected content to an article or you can add an entire 
document to an article.

To create an article and add content to it:

1. Open a multipage InDesign document that contains a 
range of text, images, and artwork.

2. Choose Window > Articles to open the Articles panel.

3. Click the Selection tool in the Tools panel.

4. Select the page items to add to the article.

5. Do one of the following:

• Choose New Article from the Articles panel menu.

• Click the Create New Article button at the bottom of 
the Articles panel.

• Drag story or page items to the Articles panel 
(Figure 2).

Figure 2 Dragging an object into the Articles panel

Create New Article 
button

Add Selection To 
Article button
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The New Article dialog box opens (Figure 3)

6. In the New Article dialog box, enter a name for the article 
(Figure 3).

7. Select Include When Exporting to add the article to the 
EPUB/HTML export output.

8. Click OK.

The selected items are added to the Articles panel.

Figure 3 New Article dialog box

To add all page items in a document to an article:

1. In the Articles panel, select an article to add the items to. 

If you don’t select an article, InDesign creates a new 
article.

2. Press Ctrl (Windows) or Command (Mac OS) and then 
click the Add Selection To Article button in the Articles 
panel (Figure 2).

All page items are added to the Articles panel.

3. If a New Article dialog box opens, enter a name for the 
article.

4. Select Include When Exporting to add the article to the 
EPUB/HTML export.

5. Click OK.

Figure 4 All objects in a document added to Article 

To manage articles for export:

1. Drag items in the Articles panel to change the order or 
move them from one article to another. 

2. To include an article while exporting, select the article in 
the Articles panel and do one of the following:

• Select the check box next to the article.

• Choose Article Options from the Articles panel 
menu and then select Include When Exporting.

Note: By default, all articles are selected for export.

Figure 5 All objects added to Articles panel

Include In Export check box
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Export content for EPUB

You can export a document or book as a reflowable eBook in EPUB format compatible with the Adobe Digital 
Editions reader software and other eBook reader software.

InDesign creates a single .epub file containing the XHTML-based content. You can choose to include a cover image 
with the exported file. InDesign creates the cover image from a designated image or froma JPEG thumbnail image 
from the first page in the specified document (or the style source document if a book was selected). The thumbnail is 
used to depict the book in EPUB readers or the Digital Editions Reader library view. To view the file, you need an 
EPUB reader. You can also use the Adobe Digital Editions software, which you can download free from the Adobe 
website.

To publish for EPUB:

1. Do one of the following:

• Open the document and choose File > Export.

• Open a book, and from the Book panel menu, choose 
Export Book To EPUB.

2. Specify a filename and location.

3. Select EPUB from the Save As Type menu (Windows) or 
the Format menu (Mac OS), and then click Save 
(Figure 6). 

4. In the EPUB Export Options dialog box, specify the 
desired options in the General, Image, and Advanced 
categories.

5. Click OK.

Figure 6 Export dialog box

Figure 7 EPUB Export Options dialog box
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Export content to HTML

Exporting to HTML is an easy way to get your InDesign content into web-ready form. When you export content to 
HTML, you can control how text and images are exported. InDesign preserves the names of paragraph, character, 
object, table, and cell styles applied to the exported contents by marking the HTML contents with CSS style classes 
of the same name. Using Adobe Dreamweaver or any CSS-capable HTML editor, you can quickly apply formatting 
and layout to the contents. 

What gets exported InDesign exports all stories, linked and embedded graphics, SWF movie files, footnotes, text 
variables (as text), bulleted and numbered lists, internal cross-references, and hyperlinks that jump to text or web 
pages. Tables are also exported, but certain formatting, such as table and cell strokes, is not exported. Tables are 
assigned unique IDs so they can be referenced as Spry data sets in Dreamweaver. Placed audio and h.264 video files 
are enclosed in HTML5 <audio> and <video> tags.

What doesn’t get exported InDesign does not export objects you draw (such as rectangles, ovals, and polygons), 
hyperlinks (except for links to web pages and links applied to text that jump to text anchors in the same document), 
pasted objects (including pasted Illustrator images), text converted to outlines, XML tags, books, bookmarks, SING 
glyphlets, page transitions, index markers, objects on the pasteboard that aren’t selected and don’t touch the page,  
master page items (unless they’re overridden or selected before export).

For advanced HTML export options, see InDesign Help. 

To export content to HTML:

1. Do one of the following:

• Open the document and choose File > Export.

• Open a book, and from the Book panel menu, choose 
Export Book To HTML.

2. Specify a filename and location.

3. Select HTML from the Save As Type menu (Windows) 
or the Format menu (Mac OS), and then click Save 
(Figure 6).

4. In the HTML Export Options dialog box, specify the 
desired options in the General, Image, and Advanced 
categories (Figure 8).

If you have organized your content by using the Articles 
panel, make sure the Same As Articles Panel option (in 
the Content Order area) is selected.

5. Click OK.

Figure 8 HTML Export Options dialog box

Same As Articles Panel option 
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Adobe InDesign – Study Guide Sample Items 

SELECTED RESPONSE EXAMPLES 

3980 - You have a client that wants you to get images for a project you are working on. How can 
you legitimately get free images for their project? 

 

3984 - Which option is the appropriate document setting for print design? 

A PPI 
B BMP 
C RTF 
D DPI 

Answer: D 

3985 - When resampling an image, what are you doing to it? 



A Changing the total number of pixels 
B Changing the actual size of the image 
C Changing the color scheme of the image 
D Changing the print vs. web option 

Answer: A 

3987 - What is typography? 

A The term used when referring to printing text 
B The arrangement and type of fonts used 
C A specific font family 
D The color choice of the text 

Answer: B 

3996 - You are creating a document with many different objects, images, and text types. What is 
the best way to edit each section? 

A Put each section on a different page 
B Put each section in its own text or object box 
C Put each section on its own layer 
D Put each section in its own swatch 

Answer: C 

4004 - Which three options are uses for frames in InDesign? (Choose three.) 

A Cropping an object 
B Masking an object 
C Creating a custom page size 
D Creating a border or background 

Answer: A, B, D 

4130 - Which two options are appropriate color settings for print or web? (Choose two.) 

A RTF 
B RGB 
C Greyscale 
D TIFF 

Answer: B and C 

 

 



3999 - Delete the third page from the document. 

 

 

 

 

 

 

 

 

 

 

 



4001 - Edit the Title paragraph style so that it uses a Center alignment.  
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